码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1016 Prime Ring Problem(深度优先搜索)

时间:2014-10-10 23:15:04      阅读:276      评论:0      收藏:0      [点我收藏+]

标签:搜索   dfs   素数环   

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27488 Accepted Submission(s): 12248


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

bubuko.com,布布扣

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
6 8

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
问题描述:将从1到n这n个整数围成一个圆环,若其中任意2个相邻的数字相加,结果均为素数,那么这个环就成为素数环。
n=20时,下面的序列就是一个素数环:
1 2 3 4 7 6 5 8 9 10 13 16 15 14 17 20 11 12 19 18

思路如下:
对除奇数个以外的20以内的所有情况进行筛选,若能同时满足相邻相加为素数,且保证在数组中第一次使用则可选,向下继续搜索。关于素数的判断,建议提前打表,节约时间啊有木有。。。
#include<iostream>
#include<cmath>
using namespace std;
int t[21];
int pre[20];
int N,count;
int prime(int m)
{
	int x=(int)sqrt((double)m);
	for(int k=2;k<=x;k++)
	{
		if(m%k==0)
			return 0;
	}
	return 1;
}
int judge(int m)
{
	for(int i=1;i<=N&&t[i]!=0;i++)
	{
		if(m==t[i])
			return 0;
	}
	return 1;
}
int prim(int m)
{
	for(int i=0;i<20;i++)
		if(m==pre[i])return 1;
		return 0;
}
void DFS(int n)
{
	if(n==N+1)
	{
		if(prime(t[N]+t[1]))
		{
			
			for(int k=1;k<N;k++)
				cout<<t[k]<<" ";
			cout<<t[N]<<endl;
		}
	}
	for(int i=2;i<=N;i++)
	{
		
		if(judge(i)&&prim(t[n-1]+i))
		{
			
			t[n]=i;
			DFS(n+1);
			t[n]=0;
		}
	}
}
int main()
{
	int k=0;
	for(int i=2;i<40;i++)
		if(prime(i))
			pre[k++]=i;
		while(cin>>N&&N%2==0)
		{
			count++;
			cout<<"Case "<<count<<":"<<endl;
			memset(t,0,sizeof(t));
			t[1]=1;
			DFS(2);
			cout<<endl;
		}
		return 0;
}

之后看了一个别人的,发现也是不错的哦,时间和空间上都有很大的优化。
#include"stdio.h"
#include"string.h"
int n;
int a[123],used[123];
int ok(int n)
{
    int i;
    for(i=2;i<n;i++)
    {
        if(n%i==0) return 0;
    }
    return 1;
}
void dfs(int x)
{
    int i;
    if(x==n)
    {
        int j;
        if(ok(1+a[x-1])==1)  //头尾和判断
        {
            printf("1");
            for(j=1;j<n;j++)  printf(" %d",a[j]);  //构造够n个了 输出数组。
            printf("\n");
            return ;
        }
    }
    for(i=2;i<=n;i++)
    {
        if(used[i]==0&&ok(i+a[x-1])==1)  //加上判断和是不是素数
        {
            a[x]=i;
            used[i]=1;  //标记使用了
            dfs(x+1);    //对第x+1个进行构造
            used[i]=0;  //标记复原
        }
    }
    return ;
}
int main()
{
    int cas=1;
    while(scanf("%d",&n)!=-1)
    {
        memset(used,0,sizeof(used)); // 赋值都没被使用过。
        used[1]=1;
        a[0]=1;

        printf("Case %d:\n",cas++);
        dfs(1);  //从第1个数开始构造,因为以1开始
        printf("\n");
    }
    return 0;
}
这里注意,used数组是用来标记已被选用的i值,而a数组则是从0开始存储依次选取的数值,这也正解决了一个数组无法使用标记搜索。

HDU1016 Prime Ring Problem(深度优先搜索)

标签:搜索   dfs   素数环   

原文地址:http://blog.csdn.net/u014492609/article/details/39968179

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!