码迷,mamicode.com
首页 > 其他好文 > 详细

字符个数

时间:2018-10-23 20:49:55      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:nts   amp   std   --   component   let   pac   print   英文   

输入一行字符,分别统计出其中英文字母、数字、空格和其他字符的个数。

 

输入

一行字符

输出

统计值

样例输入

aklsjflj123 sadf918u324 asdf91u32oasdf/.‘;123

样例输出

23 16 2 4
#include <stdio.h>
int main()
{
 int letter=0,space=0,number=0,others=0;
 char nextchar;
 for(;nextchar!=\n;)
 {
  scanf("%c",&nextchar);
  if((a<=nextchar&&nextchar<=z)||(A<=nextchar&&nextchar<=Z))
   letter++;
  else if(nextchar== )
   space++;
  else if(0<=nextchar&&nextchar<=9)
   number++;
  else
   others++;
 }
 printf("%d %d %d %d\n",letter,number,space,--others);
    return 0;
}

 

字符个数

标签:nts   amp   std   --   component   let   pac   print   英文   

原文地址:https://www.cnblogs.com/Lazy-Cat/p/9838261.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!