码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 甲级 1031 Hello World for U

时间:2018-10-24 22:12:39      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:char s   sha   top   ensure   form   msu   pre   text   out   

https://pintia.cn/problem-sets/994805342720868352/problems/994805462535356416

 

Given any string of N (≥) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n?1??characters, then left to right along the bottom line with n?2?? characters, and finally bottom-up along the vertical line with n?3?? characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n?1??=n?3??=max { k | kn?2?? for all 3 } with n?1??+n?2??+n?3???2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

代码:

#include <bits/stdc++.h>
using namespace std;

char s[88];
char maze[88][88];
int n1, n2, n3;

int main() {
    memset(maze, ‘ ‘, sizeof(maze));
    scanf("%s", s);
    int len = strlen(s);
    len += 2;
    n1 = n3 = len / 3;
    n2 = len / 3 + len % 3;
    int cnt = 0;

    for(int i = 0; i < n1; i ++)
        maze[i][0] = s[cnt ++];
    for(int i = 1; i <= n2 - 2; i ++)
        maze[n1 - 1][i] = s[cnt ++];
    for(int i = n1 - 1; i >= 0; i --)
        maze[i][n2 - 1] = s[cnt ++];

    for(int i = 0; i < n1; i ++) {
        for(int j = 0; j < n2; j ++) {
            printf("%c", maze[i][j]);
        }
        printf("\n");
    }
    return 0;
}

  

PAT 甲级 1031 Hello World for U

标签:char s   sha   top   ensure   form   msu   pre   text   out   

原文地址:https://www.cnblogs.com/zlrrrr/p/9845777.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!