码迷,mamicode.com
首页 > 其他好文 > 详细

Hdoj 1003.Max Sum 题解

时间:2018-10-27 22:09:34      阅读:189      评论:0      收藏:0      [点我收藏+]

标签:turn   put   sub   blank   lines   tmp   rip   more   最大连续子序列   

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

Author

Ignatius.L


思路

最大连续子序列和问题,状态转移方程式:

\(f[i] = max(f[i-1]+a[i],a[i])\)

可以得出代码如下

代码

#include<bits/stdc++.h>
using namespace std;
const int INF = 1<<30;
int a[100001]; 
int main()
{
    int n;
    cin >> n;
    for(int q=1;q<=n;q++)
    {
        int len;
        cin >> len;
        
        int maxsum = -INF;
        int currentsum = 0;
        int l = 0,r = 0;
        int tmp = 1;
        for(int i=1;i<=len;i++)
        {
            cin >> a[i]; 
            if(currentsum >= 0)
                currentsum += a[i];
            else
            {
                currentsum = a[i];
                tmp = i;
            }
            if(currentsum > maxsum)
            {
                maxsum = currentsum;
                l = tmp;
                r = i;
            }   
        }
        cout << "Case " << q << ":\n";
        cout << maxsum << " " << l << " " << r << endl;
        if(q!=n) cout << endl;
    }
    return 0;
}

Hdoj 1003.Max Sum 题解

标签:turn   put   sub   blank   lines   tmp   rip   more   最大连续子序列   

原文地址:https://www.cnblogs.com/MartinLwx/p/9863574.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!