码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3734 Blocks

时间:2018-10-30 21:13:15      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:cto   contains   print   lin   type   assign   algorithm   while   快速   

http://poj.org/problem?id=3734

 

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6

题解:矩阵快速幂

代码:

#include <iostream>
#include <algorithm>
#include <math.h>
#include <vector>
#include <stdio.h>
using namespace std;

typedef long long ll;

typedef vector<ll> vec;
typedef vector<vec> mat;

const int M = 10007;
int T, N;

mat mul(mat& A, mat& B) {
    mat C(A.size(), vec(B[0].size()));
    for ( int i = 0 ; i < A.size() ;i ++) {
        for ( int k = 0 ; k < B.size() ; k ++) {
            for ( int j = 0 ; j < B[0].size() ; j ++) {
                C[i][j] = (C[i][j] + A[i][k] * B[k][j] % M) % M;
            }
        }
    }
    return C;
}

mat pow(mat A, ll n) {
    mat B(A.size(), vec(A.size()));
    for ( int i = 0 ; i < A.size() ; i ++) {
        B[i][i] = 1;
    }
    while ( n > 0 ) {
        if ( n & 1 ) B = mul(B, A);
        A = mul(A, A);
        n >>= 1;
    }
    return B;
}

void solve() {
    mat A(3, vec(3));
    A[0][0] = 2; A[0][1] = 1; A[0][2] = 0;
    A[1][0] = 2; A[1][1] = 2; A[1][2] = 2;
    A[2][0] = 0; A[2][1] = 1; A[2][2] = 2;
    A = pow(A, N);
    printf("%d\n", A[0][0]);
}

int main() {
    scanf("%d", &T);
    while(T --) {
        scanf("%d", &N);
        solve();
    }
    return 0;
}

  

POJ 3734 Blocks

标签:cto   contains   print   lin   type   assign   algorithm   while   快速   

原文地址:https://www.cnblogs.com/zlrrrr/p/9879187.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!