码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1562 Oil Deposits

时间:2018-11-01 00:53:40      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:following   clu   enc   lines   any   连通   pos   hat   geo   

Oil Deposits

| Time Limit: 1000MS |   | Memory Limit: 10000K |
| Total Submissions: 21879 |   | Accepted: 11397 |

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ‘*‘, representing the absence of oil, or ‘@‘, representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1

  • 3 5
    @@*
    @
    @@*
    1 8
    @@****@*
    5 5
    ****@
    @@@
    *@**@
    @@@*@
    @@**@
    0 0

Sample Output

0
1
2
2

Source

Mid-Central USA 1997

题解

求 @ 的连通块的问题,上下左右左上右上左下右下八个方向有 @ 的话算连通,问共有多少个连通块。用 dfs 可解决。代码如下:

#include <iostream>
#include <cstdio>
using namespace std ;

const int MAXN = 1000 ;
char arr[MAXN][MAXN] ;
int n , m ;

void dfs( int i , int j ){
    if ( i >= n || j >= m || i < 0 || j < 0 ) return ;
    if ( arr[i][j] != ‘@‘ ) return ;
    arr[i][j] = ‘*‘ ;
    for ( int a = -1 ; a <= 1 ; a ++ ){
        for ( int b = -1 ; b <= 1 ; b ++ ){
            if ( a != 0 || b != 0 ){
                dfs( i + a , b + j ) ;
            }
        }
    }
}

int main(){
    while ( cin >> n >> m && n && m ){
        for ( int i = 0 ; i < n ; i ++ ){
            for ( int j = 0 ; j < m ; j ++ ){
                cin >> arr[i][j] ;
            }
        }
        int ans = 0 ;
        for ( int i = 0 ; i < n ; i ++ ){
            for ( int j = 0 ; j < m ; j ++ ){
                if ( arr[i][j] == ‘@‘ ){
                    dfs( i , j ) ;
                    ans ++ ;
                }
            }
        }
        cout << ans << endl ;
    }
    return 0 ;
}

POJ 1562 Oil Deposits

标签:following   clu   enc   lines   any   连通   pos   hat   geo   

原文地址:https://www.cnblogs.com/Cantredo/p/9886451.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!