码迷,mamicode.com
首页 > 其他好文 > 详细

BGP联盟

时间:2018-11-01 22:41:18      阅读:28      评论:0      收藏:0      [点我收藏+]

标签:images   text   ima   6.2   bit   3.1   roc   src   oca   

BGP联盟

技术分享图片

R1:
sys
sysname R1
interface GigabitEthernet0/0/0
ip address 192.168.12.1 255.255.255.0
interface LoopBack0
ip address 10.10.1.1 255.255.255.0
bgp 100
router-id 1.1.1.1
peer 192.168.12.2 as-number 200
network 10.10.1.0 255.255.255.0
quit
quit

R2:
sys
sysname R2
interface GigabitEthernet0/0/0
ip address 192.168.23.1 255.255.255.0
interface GigabitEthernet0/0/1
ip address 192.168.12.2 255.255.255.0
interface LoopBack0
ip address 10.10.2.2 255.255.255.0
bgp 64523
router-id 2.2.2.2
confederation id 200
peer 10.10.3.3 as-number 64523
peer 10.10.3.3 connect-interface LoopBack0
peer 192.168.12.1 as-number 100
peer 10.10.3.3 next-hop-local
ospf 1 router-id 2.2.2.2
area 0.0.0.0
network 10.10.2.0 0.0.0.255
network 192.168.23.0 0.0.0.255
quit
quit

R3:
sys
sysname R3
interface GigabitEthernet0/0/0
ip address 192.168.34.1 255.255.255.0
interface GigabitEthernet0/0/1
ip address 192.168.23.2 255.255.255.0
interface LoopBack0
ip address 10.10.3.3 255.255.255.0
bgp 64523
router-id 3.3.3.3
confederation id 200
confederation peer-as 64545
peer 10.10.2.2 as-number 64523
peer 10.10.2.2 connect-interface LoopBack0
peer 10.10.4.4 as-number 64545
peer 10.10.4.4 ebgp-max-hop 255
peer 10.10.4.4 connect-interface LoopBack0
ospf 1 router-id 3.3.3.3
area 0.0.0.0
network 10.10.3.0 0.0.0.255
network 192.168.23.0 0.0.0.255
network 192.168.34.0 0.0.0.255
quit
quit

R4:
sys
sysname R4
interface GigabitEthernet0/0/0
ip address 192.168.45.1 255.255.255.0
interface GigabitEthernet0/0/1
ip address 192.168.34.2 255.255.255.0
interface LoopBack0
ip address 10.10.4.4 255.255.255.0
bgp 64545
router-id 4.4.4.4
confederation id 200
confederation peer-as 64523
peer 10.10.3.3 as-number 64523
peer 10.10.3.3 ebgp-max-hop 255
peer 10.10.3.3 connect-interface LoopBack0
peer 10.10.5.5 as-number 64545
peer 10.10.5.5 connect-interface LoopBack0
ospf 1 router-id 4.4.4.4
area 0.0.0.0
network 10.10.4.0 0.0.0.255
network 192.168.34.0 0.0.0.255
network 192.168.45.0 0.0.0.255
quit
quit

R5:
sys
sysname R5
interface GigabitEthernet0/0/0
ip address 192.168.56.1 255.255.255.0
interface GigabitEthernet0/0/1
ip address 192.168.45.2 255.255.255.0
interface LoopBack0
ip address 10.10.5.5 255.255.255.0
bgp 64545
router-id 5.5.5.5
confederation id 200
peer 10.10.4.4 as-number 64545
peer 10.10.4.4 connect-interface LoopBack0
peer 192.168.56.2 as-number 600
peer 10.10.4.4 next-hop-local
ospf 1 router-id 5.5.5.5
area 0.0.0.0
network 10.10.5.0 0.0.0.255
network 192.168.45.0 0.0.0.255
quit
quit

R6:
sys
sysname R6
interface GigabitEthernet0/0/1
ip address 192.168.56.2 255.255.255.0
interface LoopBack0
ip address 10.10.6.6 255.255.255.0
bgp 600
router-id 6.6.6.6
peer 192.168.56.1 as-number 200
network 10.10.6.0 255.255.255.0
quit
quit

验证:

BGP联盟

标签:images   text   ima   6.2   bit   3.1   roc   src   oca   

原文地址:http://blog.51cto.com/13935936/2311955

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!