码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3697 Selecting courses (暴力+贪心)

时间:2014-10-12 14:19:08      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   io   os   ar   java   for   strong   

Selecting courses

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 62768/32768 K (Java/Others)
Total Submission(s): 1856    Accepted Submission(s): 469


Problem Description
    A new Semester is coming and students are troubling for selecting courses. Students select their course on the web course system. There are n courses, the ith course is available during the time interval (Ai,Bi). That means, if you want to select the ith course, you must select it after time Ai and before time Bi. Ai and Bi are all in minutes. A student can only try to select a course every 5 minutes, but he can start trying at any time, and try as many times as he wants. For example, if you start trying to select courses at 5 minutes 21 seconds, then you can make other tries at 10 minutes 21 seconds, 15 minutes 21 seconds,20 minutes 21 seconds… and so on. A student can’t select more than one course at the same time. It may happen that no course is available when a student is making a try to select a course 

You are to find the maximum number of courses that a student can select.

 

Input
There are no more than 100 test cases.

The first line of each test case contains an integer N. N is the number of courses (0<N<=300)

Then N lines follows. Each line contains two integers Ai and Bi (0<=Ai<Bi<=1000), meaning that the ith course is available during the time interval (Ai,Bi).

The input ends by N = 0.

 

Output
For each test case output a line containing an integer indicating the maximum number of courses that a student can select.
 

Sample Input
2 1 10 4 5 0
 

Sample Output
2
 

题意是:每次选一个起始点,以后只能在+5这些点上进行选课。因为数据范围比较小,可以暴力。

枚举0、1、2、3、  4这5个起点,对于每个确定的起点可以得到一些可以进行选课的点,把选课时间段以终点进行从小到大排序,枚举可得最优解。另外,区间(a,b)可以变为[a,b),因为对于a分钟来说,a分01秒是可以选的。


#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
#define N 1005
const int inf=0x3fffffff;
int mark[N];
struct node
{
    int l,r;
}g[305];
bool cmp(node a,node b)
{
    return a.r<b.r;
}
int main()
{
    int i,j,k,r,n;
    while(scanf("%d",&n),n)
    {
        r=0;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&g[i].l,&g[i].r);
            r=max(r,g[i].r);
        }
        sort(g,g+n,cmp);
        int ans=0;
        for(i=0;i<5;i++)
        {
            memset(mark,0,sizeof(mark));
            for(j=i;j<r;j+=5)
                mark[j]=1;
            int tmp=0;
            for(j=0;j<n;j++)
            {
                for(k=g[j].l;k<g[j].r;k++)
                {
                    if(mark[k])
                    {
                        mark[k]=0;
                        tmp++;
                        break;
                    }
                }
            }
            ans=max(ans,tmp);
        }
        printf("%d\n",ans);
    }
    return 0;
}






hdu 3697 Selecting courses (暴力+贪心)

标签:des   style   color   io   os   ar   java   for   strong   

原文地址:http://blog.csdn.net/u011721440/article/details/40016711

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!