码迷,mamicode.com
首页 > 其他好文 > 详细

HDoj-1013

时间:2014-10-12 19:46:59      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:strlen   algorithm   c语言   struct   each   

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy‘s easy problem is that : give you the n,want you to find the n^n‘s digital Roots.

Input

The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).

Output

Output n^n‘s digital root on a separate line of the output.

Sample Input

2
4
0

Sample Output

4
4
#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	while(~scanf("%d",&n),n)
	{
		int s=1;
		for(int i=0;i<n;i++)
		{
			s=s*n%9;
			
		}
		if(s==0) 
		   printf("9\n");
		else
		   printf("%d\n",s);
	}
	return 0;
}


HDoj-1013

标签:strlen   algorithm   c语言   struct   each   

原文地址:http://blog.csdn.net/holyang_1013197377/article/details/40019735

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!