码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3829 Known Notation(字符串处理 数学 牡丹江现场赛)

时间:2014-10-12 23:35:08      阅读:321      评论:0      收藏:0      [点我收藏+]

标签:zoj   牡丹江   

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5383


Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven‘t learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2

Author: CHEN, Cong


题意:

给出两个操作:插入和任意交换字符串两个字母;

求最少的步数使得字符串变成后缀表达式,


PS:

发现只有缺少数字的时候才会用到插入,其他就是交换操作,把*都交换到后面,而一个*需要两个数字。



代码如下:

#include <cstdio>
#include <cstring>
int main()
{
    int t;
    char s[2017];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",s);
        int len = strlen(s);
        int cont_num = 0, cont_star = 0;
        for(int i = 0; i < len; i++)
        {
            if(s[i] == '*')
                cont_star++;
            else
                cont_num++;
        }
        int k = cont_star-cont_num+1;
        if(k < 0)
            k = 0;
        int star = 0;
        int num = k;
        int ans = k;
        for(int i = 0; i < len; i++)
        {
            if(s[i] == '*')
                star++;
            else
                num++;
            if(star+1 > num)
            {
                star--;
                num++;
                ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


ZOJ 3829 Known Notation(字符串处理 数学 牡丹江现场赛)

标签:zoj   牡丹江   

原文地址:http://blog.csdn.net/u012860063/article/details/40024425

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!