码迷,mamicode.com
首页 > 其他好文 > 详细

P1030求先序排列

时间:2018-11-23 18:28:40      阅读:193      评论:0      收藏:0      [点我收藏+]

标签:中序   new   字符串   ++   targe   main   thml   %s   初学   

这道题很重点啊。。。
首先是对树的理解,了解先序、中序、后序的排列
再自己找出排列的规律。
初学树状结构做这道题能加深自己的理解。
以及判定范围。。。40分惨痛教训。。。

 传送门

题目描述

给出一棵二叉树的中序与后序排列。求出它的先序排列。(约定树结点用不同的大写字母表示,长度≤8 \le 88)。

输入输出格式

输入格式:

222行,均为大写字母组成的字符串,表示一棵二叉树的中序与后序排列。

输出格式:

111行,表示一棵二叉树的先序。

输入输出样例

输入样例#1: 复制
BADC
BDCA
输出样例#1: 复制
ABCD
上代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<map>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
template <typename T>inline void read(T &a)
{
    bool f=0;char ch=getchar();a=0;
    while(ch<0||ch>9){if(ch==-)f=1;ch=getchar();}
    while(ch>=0&&ch<=9){a=a*10+ch-0;ch=getchar();}
    if(f==1)a=-a;
}//好习惯,虽然没用上。
char l[9],m[9];
int s;
void find(int ll,int lr,int ml,int mr)
{
    cout<<l[lr];
    if(ll==lr)
    return;
    int root;
    for(int i=ml;i<=mr;i++)
    if(m[i]==l[lr])
    {
        root=i;
        break;
    }
    if(root>ml)//判范围!!!判范围!!
    find(ll,ll+root-ml-1,ml,root-1);
    if(root<mr)//判范围!!!判范围!!
    find(ll+root-ml,lr-1,root+1,mr);
    
}
int main(){
scanf("%s",m);
scanf("%s",l);
s=strlen(l);
find(0,s-1,0,s-1);
return 0;
}

 


P1030求先序排列

标签:中序   new   字符串   ++   targe   main   thml   %s   初学   

原文地址:https://www.cnblogs.com/JCRL/p/10008878.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!