标签:one str file while turn ase and case ble
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
题意:给你一个数n,找出一个他的倍数m。(我被样例唬住了)
题解:用bfs,从1开始,两个方向(因为只有0和1组成) x*10 x*10+1,进队即可,然后判断是否是n的倍数,是就输出。
#include<iostream>
#include<queue>
typedef long long ll;
using namespace std;
int n;
void bfs(int n){
queue<ll>q;
q.push(1);
ll head;
while(!q.empty()){
head = q.front();
q.pop();
if(!(head%n)) {
cout<<head<<endl;break;
}
q.push(head*10);
q.push(head*10+1);
}
}
int main(){
while(cin>>n && n){
bfs(n);
}
return 0;
}
Find The Multiple
标签:one str file while turn ase and case ble
原文地址:https://www.cnblogs.com/stul/p/10014648.html