标签:contest test roo output mem sse tar printf start
Font Size: ← →
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges‘ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define Max 1005
using namespace std;
char a[Max][20];
int b[Max];
int main(void)
{
//freopen("in.txt","r",stdin);
int n;
while(scanf("%d",&n)!=EOF&&n)
{
getchar();
memset(b,0,sizeof(b));
for(int i=1;i<=n;i++)
gets(a[i]);
for(int i=1;i<=n;i++)
{
for(int j=i+1;j<=n;j++)
{
if(strcmp(a[i],a[j])==0)
{
b[i]++;
}
}
}
int max=0,count=1;
for(int i=1;i<=n;i++)
{
if(b[i]>max)
{
max=b[i];
count=i;
}
}
printf("%s\n",a[count]);
}
//fclose(stdin);
return 0;
}
HDOJ_1004_Let the Balloon Rise
标签:contest test roo output mem sse tar printf start
原文地址:https://www.cnblogs.com/phaLQ/p/10030048.html