码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ_1005_Number Sequence

时间:2018-11-28 12:40:36      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:number   ||   找规律   tip   roo   can   nta   ros   a*   

找规律:(0,0),(0,1)......(6,6);每次a和b的值是一样的。找规律,每49一次循环。

 

Font Size:

Problem Description

A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

AC代码:
#include <iostream>
#include <cstdio>
using namespace std;
int main(void)
{
    freopen("in.txt","r",stdin);
    int a,b;
    long long n;
    while(scanf("%d%d%lld",&a,&b,&n)!=EOF&&(a||b||n))
    {
        int x[100];
        x[1]=1;
        x[2]=1;
        for(int i=3;i<=49;i++)
            x[i]=((a*x[i-1])%7 + (b*x[i-2])%7)%7; 
        
        printf("%d\n",x[n%49]);
    }
    
    fclose(stdin);
    return 0;
}

 

HDOJ_1005_Number Sequence

标签:number   ||   找规律   tip   roo   can   nta   ros   a*   

原文地址:https://www.cnblogs.com/phaLQ/p/10030083.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!