码迷,mamicode.com
首页 > 其他好文 > 详细

Flip Game(枚举)Poj

时间:2014-10-13 19:12:17      阅读:489      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   io   os   ar   for   strong   


Flip Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 31329   Accepted: 13622

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it‘s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

bubuko.com,布布扣Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it‘s impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

题意:有16个硬币  每个硬币哟两种颜色(黑色b白色w),翻转其中任何一个硬币,其上下左右的硬币也要翻转,要求翻转最少的次数使所有的硬币达到同一种颜色,否则输出Impossible

艾玛 做了好长时间 加上大牛们的见解(让1为黑色 0为白色)  终于做出来了

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
using namespace std;
#define inf 9999999

int map[20][20];
int min_dis=inf;
void change(int x,int y//翻转棋子
{
    map[x][y]=1-map[x][y];
    map[x+1][y]=1-map[x+1][y];
    if(x>0)
        map[x-1][y]=1-map[x-1][y];
    map[x][y+1]=1-map[x][y+1];
    if(y>0)
        map[x][y-1]=1-map[x][y-1];
}
int check()//查看是否是同一颜色
{
    int i,j;
    int cnt=0;
    for(i=0;i<4;i++)
        for(j=0;j<4;j++)
        cnt+=map[i][j];
    if(cnt==0||cnt==16)//棋盘为全白或全黑
        return 1;
    else
        return 0;
}
void search(int d,int step)
{
    int x,y;
    if(d==16)
    {
        if(check()&&step<min_dis)
            {
                min_dis=step;
            }
    }
    else
    {
        x=d/4;
        y=d%4;
        search(d+1,step);
        change(x,y);
        search(d+1,step+1);
        change(x,y);
    }
}
int main()
{
    char str;
    int i,j;
    for(i=0;i<4;i++)
        for(j=0;j<4;j++)
    {
        cin>>str;
        if(str=='b')
            map[i][j]=1;
        else
            map[i][j]=0;
    }
    search(0,0);
    if(min_dis == inf)
        printf("Impossible\n");
    else
        printf("%d\n",min_dis);
    return 0;
}

Flip Game(枚举)Poj

标签:des   style   http   color   io   os   ar   for   strong   

原文地址:http://blog.csdn.net/u013486414/article/details/40047847

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!