码迷,mamicode.com
首页 > 其他好文 > 详细

02-线性结构4 Pop Sequence

时间:2018-12-05 00:18:33      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:dispose   tput   head   思维   imu   元素   结构   mat   test   

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

优秀回答:
#include <stdio.h>
#include <stdlib.h>
#define MaxSize 1000
typedef struct StackRecord{
    int capacity;
    int top;
    int data[MaxSize];
}*Stack;
Stack CreateStack(int capacity) {
    Stack S = (Stack)malloc(sizeof(struct StackRecord));
    S->top = -1;
    S->capacity = capacity;
    return S;
}
int Push(Stack S, int x) {    //将x元素入栈,如果溢出则入栈失败返回0
    if(S->capacity - S->top <= 1)
        return 0;
    S->data[++S->top] = x;
    return 1;
}
int Top(Stack S) {    //返回栈顶元素,空栈时返回-1
    if(S->top >= 0)
        return S->data[S->top];
    else
        return -1;
}
void Pop(Stack S) {    //弹出栈顶元素
    S->top--;
}
void DisposeStack(Stack S) {
    free(S);
}
//模拟进栈出栈过程:依次入栈并同时与出栈序列的第一个元素对比;若相等则弹出栈顶元素,并消去出栈序列的首元素;
//全部已入栈后出栈序列中的元素全部被消去则返回1,否则返回0;
int IsPopSeq(int* popOrder, int capacity, int n) {
    Stack S = CreateStack(capacity);
    int head = 0;        //维护一个下标,指向出栈序列中还没被消去的第一个元素
    for(int node = 1; node <= n; node++) {    //入栈节点从1到k
        if(!Push(S, node)){        //如果入栈失败表示栈满,则返回0
            DisposeStack(S);
            return 0;
        }
        while(Top(S) == popOrder[head]) {
            Pop(S);
            head++;
        }
    }
    DisposeStack(S);
    if(head != n)        //出栈序列不为空,则返回0
        return 0;
    return 1;
}
int main() {
    int m, n, k;
    scanf("%d%d%d", &m, &n, &k);
    int popOrder[1000];
    for(int i = 0; i < k; i++) {
        for(int j = 0; j < n; j++)
            scanf("%d", &popOrder[j]);
        if(IsPopSeq(popOrder, m, n))
            printf("YES\n");
        else
            printf("NO\n");
    }
 
    return 0;
}

自己,完全没有想到用什么方法来做,一开始只是觉得是不是可以找出这个输出序列的规律来排除错误情况,感觉还是没有考虑清楚自己手上有的条件,在这个题目中,输出的序列其实就是一个条件,不要仅仅考虑这个通用的解。

反思:1.多想想自己有哪些条件可用

           2.写程序,多用函数思维,方便思考与解答

           3.if条件里面可以写需要执行的语句,更加简洁,靠返回值进行判断

时间记录:2:20:0



02-线性结构4 Pop Sequence

标签:dispose   tput   head   思维   imu   元素   结构   mat   test   

原文地址:https://www.cnblogs.com/captain-dl/p/10067846.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!