码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 3829 Known Notation

时间:2014-10-13 21:59:07      阅读:292      评论:0      收藏:0      [点我收藏+]

标签:style   color   io   os   ar   for   sp   on   代码   

Known Notation

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven‘t learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2

Author: CHEN, Cong



题解及代码:

         比赛的时候坑了,思路有点漏洞。这道题目的意思就是给出一个后缀表达式,看它是否是一个合理的表达式,如果不合理,我们有两种操作:1,任意交换两个字符 2.添加一个数字或者*。其实是一道贪心的题目,我们会发现,如果有n个*的话,那么表达式里面至少要有n+1个数字,否则,我们就要加上一些数字使其满足n+1,其次贪心的策略就是把加上的数字放在表达式的最前面,然后当判断到某个*时,前面数字的数量少于2,那么我们就从这个*后面找一个数字与其换位置,直到所有的*被算完。


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

char s[1010];

int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%s",s);
        int ans=0,len=strlen(s),p=-1,nstar=0,nnum=0;
        for(int i=0;i<len;i++)
        if(s[i]=='*')
        {
            if(p<0) p=i;
            nstar++;
        }
        else nnum++;
        if(p==-1)
        {
            printf("0\n");
            continue;
        }
        int k=len-1,num=0;
        if(nstar>=nnum)
        {
            ans=(nstar-nnum+1);
            num=ans;
        }
        if(s[len-1]!='*')
        {
            ans++;
            swap(s[p],s[len-1]);
        }
        for(int i=0;i<len;i++)
        if(s[i]=='*')
        {
            if(num>=2) num--;
            else
            {
                ans++;
                while(k>i)
                {
                    if(s[k]!='*')
                    {
                        swap(s[i],s[k]);
                        num++;
                        break;
                    }
                    k--;
                }
            }
        }
        else num++;
        printf("%d\n",ans);
    }
    return 0;
}







zoj 3829 Known Notation

标签:style   color   io   os   ar   for   sp   on   代码   

原文地址:http://blog.csdn.net/knight_kaka/article/details/40052261

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!