码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 3822 Domination

时间:2014-10-13 23:39:37      阅读:297      评论:0      收藏:0      [点我收藏+]

标签:style   color   io   os   使用   ar   for   sp   on   

Domination

Time Limit: 8 Seconds      Memory Limit: 131072 KB      Special Judge

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What‘s more, he bought a large decorative chessboard with Nrows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That‘s interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= NM <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667

Author: JIANG, Kai


题解及代码:

       比赛的时候,这道题目没写出来。用dp[i][j][k]代表状态为使用k个棋子覆盖i行j列的概率,一开始的时候公式推导错了,实际上应该是下面这样的:

  i==m&&j==n  dp[i][j][k]=(m-i+1)*(n-j+1)*dp[i-1][j-1][k-1]+j*(m-i+1)*1.0*dp[i-1][j][k-1]+i*(n-j+1)*1.0*dp[i][j-1][k-1];dp[i][j][k]/=(m*n-k+1);

  else  dp[i][j][k]=(m-i+1)*(n-j+1)*dp[i-1][j-1][k-1]+j*(m-i+1)*1.0*dp[i-1][j][k-1]+i*(n-j+1)*1.0*dp[i][j-1][k-1]+(i*j-k+1)*1.0*dp[i][j][k-1];dp[i][j][k]/=(m*n-k+1);

        同时比赛的时候也没能想到(i==m&&j==n)的情况要减去蓝色的部分,以为当满足m行n列之后还能继续放棋子。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

double dp[55][55][2555];

int main()
{
    double base;
    int cas,n,m;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d%d",&m,&n);
        int maxn=n*m;
        memset(dp,0,sizeof(dp));
        dp[0][0][0]=1;
        for(int i=1;i<=m;i++)
        for(int j=1;j<=n;j++)
        {
            for(int k=1;k<=maxn;k++)
            {
                base=(double)(maxn-k+1);
                dp[i][j][k]+=(double)(m-i+1)*(n-j+1)*1.0*dp[i-1][j-1][k-1];
                dp[i][j][k]+=(double)j*(m-i+1)*1.0*dp[i-1][j][k-1];
                dp[i][j][k]+=(double)i*(n-j+1)*1.0*dp[i][j-1][k-1];
                if(i!=m||j!=n)
                dp[i][j][k]+=(double)(i*j-k+1)*1.0*dp[i][j][k-1];
                dp[i][j][k]/=base;
                //printf("dp[%d][%d][%d]:%.6lf\n",i,j,k,dp[i][j][k]);
            }
        }

        double ans=0;
        for(int i=1;i<=maxn;i++)
        {
            ans+=dp[m][n][i]*i;
        }
        printf("%.10lf\n",ans);
    }
    return 0;
}



zoj 3822 Domination

标签:style   color   io   os   使用   ar   for   sp   on   

原文地址:http://blog.csdn.net/knight_kaka/article/details/40052057

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!