码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3071-Football(概率dp)

时间:2014-10-13 23:09:47      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   io   os   ar   for   strong   sp   

Football
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3145   Accepted: 1591

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, thejth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 ? pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number ?1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2
概率dp。
题意 : 足球淘汰赛。一共有n轮,共有2^n支队伍参赛,所以总共进行n轮比赛即可决出冠军。设dp[i][j]为第i轮比赛中j队胜出的概率。则dp[i][j]=dp[i-1][j]*dp[i-1][k]*p[j][k].k为在本轮j的对手。
然后下面的问题是如何求出k。可以列出在2进制状态下的比赛过程,然后可以发现规律:j>>i-1^1==k>>i-1;
#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
using namespace std;
#define ll long long
double dp[8][130],p[130][130];
int main()
{
  int n;
  while(scanf("%d",&n)!=EOF&&n!=-1)
  {
  	int num=1<<n;
  	memset(dp,0,sizeof(dp));
  	for(int i=0;i<num;i++)
	{
		for(int j=0;j<num;j++)
		scanf("%lf",&p[i][j]);
	    dp[0][i]=1;
	}
	for(int i=1;i<=n;i++)
		for(int j=0;j<num;j++)
		for(int k=0;k<num;k++)
	    {
		    if((j>>(i-1)^1)==(k>>i-1))
				dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
	    }
	int ans;double Max=-1;
	for(int i=0;i<num;i++)
	{
		if(dp[n][i]>Max)
		{
			ans=i+1;
			Max=dp[n][i];
		}
	}
	printf("%d\n",ans);
  }
  return 0;
}


POJ 3071-Football(概率dp)

标签:des   style   color   io   os   ar   for   strong   sp   

原文地址:http://blog.csdn.net/qq_16255321/article/details/40051183

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!