码迷,mamicode.com
首页 > 其他好文 > 详细

EXPEDI - Expedition 优先队列

时间:2018-12-08 11:26:16      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:nat   解决   nes   else   stop   term   sans   bit   sar   

题目描述

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck‘s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

输入输出格式

输入格式:

The first line of the input contains an integer t representing the number of test cases. Then t test cases follow. Each test case has the follwing form:

  • Line 1: A single integer, N
  • Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.
  • Line N+2: Two space-separated integers, L and P

输出格式:

For each test case, output a single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

输入输出样例

输入样例#1: 复制
1
4
4 4
5 2
11 5
15 10
25 10
输出样例#1: 复制
2

Input details
The truck is 25 units away from the town; the truck has 10 units
of fuel.  Along the road, there are 4 fuel stops at distances 4,
5, 11, and 15 from the town (so these are initially at distances
21, 20, 14, and 10 from the truck).  These fuel stops can supply
up to 4, 2, 5, and 10 units of fuel, respectively.

Output details:
Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more
units, stop to acquire 5 more units of fuel, then drive to the town.

Priority_queue即可解决;
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
//#pragma GCC optimize(2)
//#include<cctype>
//#pragma GCC optimize("O3")
using namespace std;
#define maxn 100005
#define inf 0x3f3f3f3f
#define INF 9999999999
#define rdint(x) scanf("%d",&x)
#define rdllt(x) scanf("%lld",&x)
#define rdult(x) scanf("%lu",&x)
#define rdlf(x) scanf("%lf",&x)
#define rdstr(x) scanf("%s",x)
typedef long long  ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const long long int mod = 1e9 + 7;
#define Mod 1000000000
#define sq(x) (x)*(x)
#define eps 1e-3
typedef pair<int, int> pii;
#define pi acos(-1.0)
//const int N = 1005;
#define REP(i,n) for(int i=0;i<(n);i++)

inline ll rd() {
    ll x = 0;
    char c = getchar();
    bool f = false;
    while (!isdigit(c)) {
        if (c == ‘-‘) f = true;
        c = getchar();
    }
    while (isdigit(c)) {
        x = (x << 1) + (x << 3) + (c ^ 48);
        c = getchar();
    }
    return f ? -x : x;
}

ll gcd(ll a, ll b) {
    return b == 0 ? a : gcd(b, a%b);
}
ll sqr(ll x) { return x * x; }

/*ll ans;
ll exgcd(ll a, ll b, ll &x, ll &y) {
    if (!b) {
        x = 1; y = 0; return a;
    }
    ans = exgcd(b, a%b, x, y);
    ll t = x; x = y; y = t - a / b * y;
    return ans;
}
*/



ll qpow(ll a, ll b, ll c) {
    ll ans = 1;
    a = a % c;
    while (b) {
        if (b % 2)ans = ans * a%c;
        b /= 2; a = a * a%c;
    }
    return ans;
}

struct node {
    int dis, sum;
}stp[maxn];

bool cmp(node a, node b) {
    return a.dis < b.dis;
}

int T;
int l, p;
int main()
{
    //ios::sync_with_stdio(0);
    rdint(T);
    while (T--) {
        ms(stp); int n; rdint(n);priority_queue<int>q;
        for (int i = 0; i < n; i++)rdint(stp[i].dis), rdint(stp[i].sum);
        rdint(l); rdint(p);
        for (int i = 0; i < n; i++)stp[i].dis = l - stp[i].dis;
        stp[n].dis = l; stp[n].sum = 0;
        n++;
        sort(stp, stp + n, cmp);
        int cnt = p, loct = 0;// 油量为cnt,距出发点距离为loct
        bool fg = 0;
        int ans = 0;
        for (int i = 0; i < n; i++) {
            int Dis = stp[i].dis - loct;
            while (Dis > cnt) {
                if (q.empty()) {
                    fg = 1; break;
                }
                else {
                    int tmp = q.top(); q.pop();
                    cnt += tmp; ans++;
                }
            }
            if (fg)break;
            cnt -= Dis;
            q.push(stp[i].sum);
            loct = stp[i].dis;
        }
        if (fg)cout << -1 << endl;
        else cout << ans << endl;
    }
    return 0;
}

 


EXPEDI - Expedition 优先队列

标签:nat   解决   nes   else   stop   term   sans   bit   sar   

原文地址:https://www.cnblogs.com/zxyqzy/p/10086093.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!