码迷,mamicode.com
首页 > 其他好文 > 详细

HDU6292 赛题分析【水题】

时间:2018-12-22 17:25:10      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:arch   i+1   const   c语言程序   std   names   for   表示   解释   

赛题分析

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1506 Accepted Submission(s): 637

Problem Description
著名出题人小Q每次比赛后都会写一份《赛题分析》,包含比赛概况、每题的参考算法以及一些统计数值。

对于一道题来说,小Q会统计最短的验题人代码长度(Shortest judge solution)以及赛内参赛队伍最短的AC代码长度(Shortest team solution)。

统计验题人代码长度比较容易,因为验题人最多也不会超过20个。但是统计选手代码长度就不容易了,因为大赛区动辄三四百支队伍。

请写一个程序,帮助小Q统计最短代码长度。

Input
第一行包含一个正整数T(1≤T≤13),表示赛题数量。

每道题第一行包含两个整数n,m(2≤n≤20,0≤m≤500),分别表示验题人数量以及AC了该题的队伍数量。

第二行包含n个正整数a1,a2,...,an(50≤ai≤65536),依次表示每个验题人的代码字节数。

第三行包含m个正整数b1,b2,...,bn(50≤bi≤65536),依次表示每支AC队伍的代码字节数。若m=0则该行为空行。

Output
对于第i(1≤i≤T)道题,输出三行,第一行输出Problem x:,其中x=i+1000。

第二行输出Shortest judge solution: y bytes.,其中y表示最短的验题人代码字节数。

第三行输出Shortest team solution: z bytes.,其中z表示最短的选手代码字节数,若不存在请输出N/A。

注意:间隔都是一个空格。

Sample Input
2
3 2
3627 1460 5288
2365 2671
2 0
5510 7682

Sample Output
Problem 1001:
Shortest judge solution: 1460 bytes.
Shortest team solution: 2365 bytes.
Problem 1002:
Shortest judge solution: 5510 bytes.
Shortest team solution: N/A bytes.

Source
"字节跳动杯"2018中国大学生程序设计竞赛-女生专场

问题链接HDU6292 赛题分析
问题描述:(略)
问题分析
????这是一个极值计算的简单题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* HDU6292 赛题分析 */

#include <bits/stdc++.h>

using namespace std;

const int SUP = 1e6;

int main()
{
    int t;
    scanf("%d", &t);
    for(int caseno = 1; caseno <= t; caseno++) {
        printf("Problem %d:\n", 1000 + caseno);
        int n, m, a, mina = SUP;
        scanf("%d%d", &n, &m);

        for(int i = 1; i <= n; i++) {
            scanf("%d", &a);
            mina = min(mina, a);
        }
        printf("Shortest judge solution: %d bytes.\n", mina);

        if(m == 0)
            printf("Shortest team solution: N/A bytes.\n");
        else {
            mina = SUP;
            for(int i = 1; i <= m; i++) {
                scanf("%d", &a);
                mina = min(mina, a);
            }
            printf("Shortest team solution: %d bytes.\n", mina);
        }
    }

    return 0;
}

HDU6292 赛题分析【水题】

标签:arch   i+1   const   c语言程序   std   names   for   表示   解释   

原文地址:https://www.cnblogs.com/tigerisland45/p/10161639.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!