码迷,mamicode.com
首页 > 其他好文 > 详细

uva 10020 Minimal coverage 【贪心】+【区间完全覆盖】

时间:2014-10-14 23:52:09      阅读:247      评论:0      收藏:0      [点我收藏+]

标签:贪心   区间完全覆盖   

  Minimal coverage 

The Problem

Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].

The Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".

Each test case will be separated by a single line.

The Output

For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

1
-1 0
-5 -3
2 5
0 0

1
-1 0
0 1
0 0

Sample Output

0

1
0 1


题意:用最少的区间覆盖(0,m)这个区间。

分析:尽量选覆盖目的区间大的区间。我们可以按照每个给的区间的最左端端点排序,从左端点小于st的区间中选取右端点最大的区间赋给en。这时候再比较st=en与m的大小,不满足k>=m,继续上面的循环,直到满足,或者找不到可以覆盖的区间。 详情看代码。

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#define M 100005
using namespace std;
struct node{
	int st, en;
}s[M];
int ans[M];

int cmp(node a, node b){
	if(a.st == b.st) return a.en>b.en;
	return a.st < b.st;
}
int main(){
	int t, m;
	scanf("%d", &t);
	while(t --){
		scanf("%d", &m);
		int tot = 0, a, b;
		while(scanf("%d%d", &a, &b), a||b){
			if(a>b) swap(a, b);
			s[tot].st = a; s[tot].en = b;
			++tot;
		}
		sort(s, s+tot, cmp);
		int st, en, num;
		st = en = num = 0;
		while(st<m){
			en = st;
			for(int i = 0; i < tot; i ++){
				if(s[i].st<=st&&s[i].en>en){  //从左端点小于st的区间中找出右端点最大的赋给en,并且用ans【num】储存右端点最大的区间的下标
					en = s[i].en; ans[num] = i; 
				}
			}
			if(en == st){  //如果没有找到,可以继续覆盖的区间,直接跳出来。
				num = 0; break;
			}
			st = en;
			++num;
		}
		cout<<num<<endl;
		for(int i = 0; i < num; i++)
			cout<<s[ans[i]].st<<" "<<s[ans[i]].en<<endl;
	}
	exit(0);
}


uva 10020 Minimal coverage 【贪心】+【区间完全覆盖】

标签:贪心   区间完全覆盖   

原文地址:http://blog.csdn.net/shengweisong/article/details/40085379

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!