码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1151 poj1422 最小路径覆盖.最大二分匹配

时间:2014-10-14 23:36:29      阅读:217      评论:0      收藏:0      [点我收藏+]

标签:最小路径覆盖   最大流   

Air RaidTime Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

Appoint description:

Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town‘s streets you can never reach the same intersection i.e. the town‘s streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town‘s streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output

2
1

求最小路径覆盖(需要几条路才能无重复的走完所有点),最小路径覆盖等于顶点个数减去最大二分匹配数目。

因为如果没有任何边的话,每个点都需要一条路径,加入一条边后需要的路径减少一条,但是不能走重复的点所以就是二分匹配问题。要求最小路径覆盖就是要求最大二分匹配,代码如下:


/*************************************************************************
    > File Name: c.cpp
    > Author: acvcla
    > QQ: 
    > Mail: acvcla@gmail.com 
    > Created Time: 2014年10月11日 星期六 08时42分28秒
 ************************************************************************/
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<cstring>
#include<map>
#include<queue>
#include<stack>
#include<string>
#include<cstdlib>
#include<ctime>
#include<set>
#include<math.h>
using namespace std;
typedef long long LL;
const int maxn = 1e2 + 50;
#define rep(i,a,b) for(int i=(a);i<=(b);i++)
#define pb push_back
bool vis[maxn];
int d[maxn];
std::vector<int>G[maxn];
void init(int n){
	memset(vis,0,sizeof vis);
	memset(d,-1,sizeof d);
	for(int i=0;i<=n;i++)G[i].clear();
}
void addadge(int u,int v){
	G[u].pb(v);
}
bool match(int u){
	for(int i=0;i<G[u].size();++i){
		int &v=G[u][i];
		if(!vis[v]){
			vis[v]=1;
			if(d[v]==-1||match(d[v])){
				d[v]=u;
				return true;
			}
		}
	}
	return false;
}
int main(){
		ios_base::sync_with_stdio(false);
		cin.tie(0);
		int T,n,m;
		cin>>T;while(T--){

			while(cin>>n>>m){
			init(n);	int u,v;
			while(m--){
				cin>>u>>v;
				addadge(u,v);
			}
			int ans=n;
			for(int i=1;i<=n;i++){
				memset(vis,0,sizeof v);
				if(match(i))ans--;
			}
			cout<<ans<<endl;
		}
		}
		return 0;
}


后来用网络流写了一发。。。居然tle了,还不知道原因,求指教,代码如下


/*************************************************************************
    > File Name: c.cpp
    > Author: acvcla
    > QQ
    > Mail: acvcla@gmail.com 
    > Created Time: 2014年10月13日 星期一 22时26分17秒
 ************************************************************************/
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<cstring>
#include<map>
#include<queue>
#include<stack>
#include<string>
#include<cstdlib>
#include<ctime>
#include<set>
#include<math.h>
using namespace std;
typedef long long LL;
const int maxn = 1e2 + 30;
const int INF =1e7;
#define rep(i,a,b) for(int i=(a);i<=(b);i++)
#define pb push_back
int n,m,s,t;
int d[maxn],cur[maxn];
struct  Edge
{
	int from,to,cap,flow;
};
std::vector<int>G[maxn];
std::vector<Edge>edges;
void init(int n){
	for(int i=0;i<n;i++)G[i].clear();
	edges.clear();
}
void addEdge(int u,int v)
{
	edges.pb((Edge){u,v,1,0});
	edges.pb((Edge){v,u,0,0});
	int sz=edges.size();
	G[u].pb(sz-2);
	G[v].pb(sz-1);
}
int bfs(){
	memset(d,0,sizeof d);
	queue<int>q;
	q.push(s);
	while(!q.empty()){
		int u=q.front();q.pop();
		for(int i=0;i<G[u].size();i++){
			Edge &e=edges[G[u][i]];
			if(e.to==s)continue;
			if(!d[e.to]&&e.cap>e.flow){
				q.push(e.to);
				d[e.to]=d[u]+1;
			}
		}
	}
	//cout<<t<<' '<<d[t]<<endl;
	return d[t];
}
int dfs(int u,int a)
{
	if(u==t||a==0)return a;
	int flow=0,f=0;
	for(int &i=cur[u];i<G[u].size();++i){
		Edge &e=edges[G[u][i]];
		if(d[e.to]==d[u]+1&&(f=dfs(e.to,min(a,e.cap-e.flow)))>0){
			e.flow+=f;
			edges[G[u][i]^1].flow-=f;
			flow+=f;
			if(a==0)break;
		}

	}
	return flow;
}
int Dinic(){
	int flow=0;
	while(bfs()){
		memset(cur,0,sizeof cur);
		flow+=dfs(s,INF);
	}
	return flow;
}
int main(){
		ios_base::sync_with_stdio(false);
		cin.tie(0);
		int T;scanf("%d",&T);
		while(T--){
			scanf("%d%d",&n,&m);
			int u,v;
			s=0,t=n+1;
			init(t);
			while(m--){
				scanf("%d%d",&u,&v);
				addEdge(s,u);
				addEdge(u,v);
				addEdge(v,t);
			}
			//cout<<"Dinic"<<endl;
			cout<<t-Dinic()<<endl;
		}
		return 0;
}


hdu1151 poj1422 最小路径覆盖.最大二分匹配

标签:最小路径覆盖   最大流   

原文地址:http://blog.csdn.net/acvcla/article/details/40085183

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!