码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4802-GPA(水)

时间:2014-10-14 22:48:59      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   java   

GPA

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1471    Accepted Submission(s): 902


Problem Description
In college, a student may take several courses. for each course i, he earns a certain credit (ci), and a mark ranging from A to F, which is comparable to a score (si), according to the following conversion table
bubuko.com,布布扣

The GPA is the weighted average score of all courses one student may take, if we treat the credit as the weight. In other words,
bubuko.com,布布扣

An additional treatment is taken for special cases. Some courses are based on “Pass/Not pass” policy, where stude nts earn a mark “P” for “Pass” and a mark “N” for “Not pass”. Such courses are not supposed to be considered in computation. These special courses must be ignored for computing the correct GPA.
Specially, if a student’s credit in GPA computation is 0, his/her GPA will be “0.00”.
 

Input
There are several test cases, please process till EOF.
Each test case starts with a line containing one integer N (1 <= N <= 1000), the number of courses. Then follows N lines, each consisting the credit and the mark of one course. Credit is a positive integer and less than 10.
 

Output
For each test case, print the GPA (rounded to two decimal places) as the answer.
 

Sample Input
5 2 B 3 D- 2 P 1 F 3 A 2 2 P 2 N 6 4 A 3 A 3 A 4 A 3 A 3 A
 

Sample Output
2.33 0.00 4.00
#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
using namespace std;
#define ll long long
int main()
{
  int n,x;char s[5];
  while(~scanf("%d",&n))
  {
  	int sum_c=0;
  	double sum_cs=0;
  	while(n--)
	{
		scanf("%d %s",&x,s);
		if(s[0]=='P'||s[0]=='N')
			continue;
		sum_c+=x;
		double tem;
		if(strlen(s)==1)
		{
			switch (s[0])
			{
				case 'A':tem=4;break;
				case 'B':tem=3;break;
				case 'C':tem=2;break;
				case 'D':tem=1.3;break;
				case 'F':tem=0;break;
			}
		}
		else
		{
			if(!strcmp(s,"A-"))
				tem=3.7;
			else if(!strcmp(s,"B+"))
				tem=3.3;
			else if(!strcmp(s,"B-"))
				tem=2.7;
			else if(!strcmp(s,"C+"))
				tem=2.3;
			else if(!strcmp(s,"C-"))
				tem=1.7;
			else if(!strcmp(s,"D-"))
				tem=1.0;
		}
		sum_cs+=(double)x*tem;
	}
	if(sum_c==0)
	{
		puts("0.00");
		continue;
	}
	printf("%.2lf\n",sum_cs/(double)sum_c);
  }
  return 0;
}

HDU 4802-GPA(水)

标签:des   style   blog   http   color   io   os   ar   java   

原文地址:http://blog.csdn.net/qq_16255321/article/details/40084687

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!