码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1058 Humble Numbers(dp)

时间:2014-10-14 23:41:13      阅读:266      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   os   ar   for   sp   div   

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1003 1069 1176 2084 1024 
 


#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<stack>
using namespace std;

#define N 5843

int a[N],c[4];

int main()
{
	int i,j;
	int x,y,z,w;
	x=y=w=z=1;
	a[0]=1;
	int temp;
	for(i=1;i<N;i++)
	{
		 c[0]=a[x-1]*2;
		 c[1]=a[y-1]*3;
		 c[2]=a[z-1]*5;
		 c[3]=a[w-1]*7;

		 temp=c[0];

		 for(j=1;j<4;j++)
			if(c[j]<temp)
			  temp=c[j];

		 if(c[0]==temp)
			x++;

		if(c[1]==temp)
			y++;

		if(c[2]==temp)
			z++;

		if(c[3]==temp)
			w++;

		a[i]=temp;
	}

		int n;
		while(~scanf("%d",&n),n)
		{
			if(n%10==1&&n%100!=11)
				printf("The %dst humble number is %d.\n",n,a[n-1]);
			else
				if(n%10==2&&n%100!=12)
				printf("The %dnd humble number is %d.\n",n,a[n-1]);
			else
				if(n%10==3&&n%100!=13)
				printf("The %drd humble number is %d.\n",n,a[n-1]);
			else
				printf("The %dth humble number is %d.\n",n,a[n-1]);
		}



    return 0;
}






HDU 1058 Humble Numbers(dp)

标签:des   style   http   io   os   ar   for   sp   div   

原文地址:http://blog.csdn.net/u014737310/article/details/40083129

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!