码迷,mamicode.com
首页 > 其他好文 > 详细

HDU4268 Alice and Bob 【贪心】

时间:2014-10-15 01:06:29      阅读:326      评论:0      收藏:0      [点我收藏+]

标签:hdu4268

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2869    Accepted Submission(s): 926


Problem Description
Alice and Bob‘s game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob‘s. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob‘s cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
 

Input
The first line of the input is a number T (T <= 40) which means the number of test cases.
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice‘s card, then the following N lines means that of Bob‘s.
 

Output
For each test case, output an answer using one line which contains just one number.
 

Sample Input
2 2 1 2 3 4 2 3 4 5 3 2 3 5 7 6 8 4 1 2 5 3 4
 

Sample Output
1 2
 

Source
 

题意:一个物品有两个参数x,y,当且仅当a物品的x不小于b物品的x且a物品的y不小于b物品的y时a物品能覆盖b物品,现在有个a物品的集合和b物品的集合,问a集合最多能覆盖多少个b集合中的物品。

题解:对两个集合按照x进行升序排序,然后对a集合中的每个物品,在x满足的情况下,将对应的b集合中的物品扔入multiset中,然后在multiset中寻找y值最大的合法值,若找到++ans并将该值erase;

#include <stdio.h>
#include <string.h>
#include <set>
#include <algorithm>
using namespace std;

#define maxn 100010
#define inf 0x7fffffff

struct Node {
    int x, y;
} A[maxn], B[maxn];
int n;

bool cmp(Node a, Node b) {
    return a.x < b.x;
}

int main() {
    int t, i, j, ans;
    scanf("%d", &t);
    while(t--) {
        multiset<int> mst;
        multiset<int>::iterator it;
        scanf("%d", &n);
        for(i = 0; i < n; ++i)
            scanf("%d%d", &A[i].x, &A[i].y);
        for(i = 0; i < n; ++i)
            scanf("%d%d", &B[i].x, &B[i].y);
        sort(A, A + n, cmp);
        sort(B, B + n, cmp);
        ans = 0;
        for(i = j = 0; i < n; ++i) {
            for( ; j < n && A[i].x >= B[j].x; ++j) {
                mst.insert(B[j].y);
            }
            if(mst.empty()) continue;
            it = mst.lower_bound(A[i].y);
            if(*--it <= A[i].y) {
                ++ans; mst.erase(it);
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


HDU4268 Alice and Bob 【贪心】

标签:hdu4268

原文地址:http://blog.csdn.net/chang_mu/article/details/40086649

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!