码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1026 Cipher(置换)

时间:2014-10-15 17:34:21      阅读:274      评论:0      收藏:0      [点我收藏+]

标签:数学

                                                               Cipher

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19502   Accepted: 5239

Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message. 

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n. 

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages. 

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE

第一次做这种多个循环节,对每个循环节中的元素分开求解的题目,记录一下。


题意:给出一个n个数的置换,按照置换规则把一个字符串置换k次,如果字符串的长度不足n,则在字符串末尾补空格,直到长度为n。求置换k次之后的字符串是什么。


分析:如果直接按照题目描述的模拟,肯定会超时。
对整个字符串置换,可以转换为对每个循环节进行置换。因为一个循环节里面的元素,对其他元素没有影响,这样我们就可以先求出所有的循环节和每个循环节中的元素及循环节的长度,然后对每个循环节中的元素进行置换。一个循环节中的元素置换k次,等价于每个元素置换k%(这个元素所在循环节的长度)次,这样模拟次数变得很小,就可以模拟了。


#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <iostream>
using namespace std;

const int N = 215;
char str[N];  //原始字符串
char ans[N]; //置换后的字符串
int key[N];  //置换规则
int cnt; //循环节数量
int num[N]; //每个循环节的长度
int cir[N][N]; //cir[i][j]表示第i个循环节中的第j个元素对应的位置
int vis[N]; //记录每个数是否访问过

int n;

void get_circle() {
    memset(vis, 0, sizeof(vis));
    memset(num, 0, sizeof(num));
    cnt = 0;
    for(int i = 1; i <= n; i++) {
        if(!vis[i]) {
            vis[i] = 1;
            num[cnt] = 0;
            int tmp = key[i];
            cir[cnt][num[cnt]++] = tmp;
            while(!vis[tmp]) {
                vis[tmp] = 1;
                tmp = key[tmp];
                cir[cnt][num[cnt]++] = tmp;
            }
            cnt++;
        }
    }
}

int main() {
    int k;
    while(~scanf("%d",&n) && n) {
        for(int i = 1; i <= n; i++)
            scanf("%d", &key[i]);
        get_circle();
        while(~scanf("%d", &k) && k) {
            gets(str);
            int len = strlen(str);
            for(int i = len; i <= n; i++)
                str[i] = ' ';
            for(int i = 0; i < cnt; i++) {
                for(int j = 0; j < num[i]; j++) {
                    ans[cir[i][(j+k)%num[i]]] = str[cir[i][j]];
                } //第i个循环节中的第j个元素置换k次之后的位置为第(j+k)% num[i]
            }
            ans[n+1] = '\0';
            printf("%s\n", ans+1);
        }
        printf("\n");
    }
    return 0;
}



POJ 1026 Cipher(置换)

标签:数学

原文地址:http://blog.csdn.net/lyhvoyage/article/details/40111141

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!