码迷,mamicode.com
首页 > 其他好文 > 详细

ACM学习历程——ZOJ 3829 Known Notation (2014牡丹江区域赛K题)(策略,栈)

时间:2014-10-16 00:15:21      阅读:587      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   io   os   ar   for   sp   

Description

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven‘t learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

 

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

 

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2


这个题目要能想到匹配的策略,其实还是不是特别难的。
对于这个题目,首先要确定的前提就是数字的个数一定要大于运算符的个数,因为这是二元运算,故两个数字和一个运算符能生成一个数字。其次,这种运算法,是具备结合律的,所以,对于多个数字对应一个运算符的情况,可以就近选择一定数量的数字和运算符进行运算。
这种情况下,当运算符数目大于等于数字数目时,可以优先考虑插入数的操作,让插入的数全部插在最前面,因为结合律的缘故,这种情况是最优的。其次,只需要每个运算符前都满足:到当前为止,运算符的个数始终小于数字个数,否则,将排在当前最后一个的数字与当前运算符交换(由于结合律的关系,考虑最后一个数字)。
最后,还要考虑两个问题:
1、一开始就是纯数字的问题,这个答案应该为0;
2、执行完所有的操作,最后一个字符不是*的,答案应该再加1.


代码:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <set>
#include <map>
#include <vector>
#include <string>
#include <queue>
#define inf 0x3fffffff
#define esp 1e-10

using namespace std;

int numc, numi, len;
char s[1005];
int Stack[1005], top;

void Input ()
{
    numc = 0;
    numi = 0;
    len = 0;
    top = 0;
    char ch;
    for (;;)
    {
        ch = getchar();
        if (ch == \n)
            break;
        if (ch == *)
            numc++;
        else
        {
            numi++;
            Stack[top++] = len;
        }
        s[len++] = ch;
    }
}

int qt()
{
    if (numc == 0)
        return 0;
    int ans = 0;
    if (numi > numc)
        numi = numc = 0;
    else
    {
        ans = numi = numc - numi + 1;
        numc = 0;
    }
    for (int i = 0; i < len; ++i)
    {
        if (s[i] == *)
            numc++;
        else
            numi++;
        if (numc >= numi)
        {
            swap (s[i], s[Stack[top-1]]);
            top--;
            ans++;
            numc--;
            numi++;
        }
    }
    if (s[len-1] != *)
        ans++;
    return ans;
}

int main()
{
    //freopen ("test.txt", "r", stdin);
    int T;
    scanf ("%d", &T);
    getchar();
    for (int times = 0; times < T; ++times)
    {
        Input();
        printf ("%d\n", qt());
    }
    return 0;
}

 



ACM学习历程——ZOJ 3829 Known Notation (2014牡丹江区域赛K题)(策略,栈)

标签:des   style   blog   color   io   os   ar   for   sp   

原文地址:http://www.cnblogs.com/andyqsmart/p/4027603.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!