码迷,mamicode.com
首页 > 其他好文 > 详细

E - K-th Number POJ - 2104

时间:2019-01-21 20:06:57      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:sid   unique   bbb   query   upd   quick   first   closed   sed   

E - K-th Number POJ - 2104 

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5. 

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k). 

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment. 

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.
 
 
题意:求区间第k大
题解:主席树的板子
技术分享图片
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<sstream>
#include<cmath>
#include<stack>
#include<cstdlib>
#include <vector>
#include<queue>
using namespace std;

#define ll long long
#define llu unsigned long long
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
const int maxn =  1e5+5;
const int  mod = 1e9+7;

int n,q,m,tot;
int a[maxn],t[maxn],T[maxn],lson[maxn*30],rson[maxn*30],c[maxn*30];

void Init_hash()
{
    for(int i=1;i<=n;i++)
        t[i] = a[i];
     sort(t+1,t+1+n);
     m = unique(t+1,t+1+n)-t-1;
}

int build(int l,int r)
{
    int root = tot++;
    c[root] = 0;
    if (l != r)
    {
        int mid = (l+r) >> 1;
        lson[root] = build(l,mid);
        rson[root] = build(mid+1,r);
    }
    return root;
}
int Hash(int x)
{
    return lower_bound(t+1,t+1+m,x)-t;
}
int update(int root,int pos,int val)
{
    int newroot = tot ++,tmp = newroot;
    c[newroot] = c[root] + val;
    int l = 1,r = m;
    while(l <r)
    {
        int mid = (l+r)>>1;
        if(pos <= mid)
        {
            lson[newroot] = tot++;
            rson[newroot] = rson[root];
            newroot = lson[newroot];
            root = lson[root];
            r = mid;
        }
        else
        {
            rson[newroot] = tot ++;
            lson[newroot] = lson[root];
            newroot = rson[newroot];
            root = rson[root];
            l = mid + 1;
        }
        c[newroot] = c[root] + val;
    }
    return tmp;

}
int query(int left_root,int right_root,int k)
{
    int l = 1,r = m;
    while(l < r)
    {
        int mid = (l+r) >> 1;
        if(c[lson[left_root]] - c[lson[right_root]] >= k)
        {
            r = mid;
            left_root = lson[left_root];
            right_root = lson[right_root];
        }
        else
        {
            l = mid + 1;
            k -= c[lson[left_root]] - c[lson[right_root]];
            left_root = rson[left_root];
            right_root = rson[right_root];
        }
    }
    return l;
}
int main()
{
    scanf("%d%d",&n,&q);
    tot = 0;
    for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
    Init_hash();
    T[n+1] = build(1,m);
    for(int i=n;i;i--)
    {
        int pos = Hash(a[i]);
        T[i] = update(T[i+1],pos,1);
    }
    while(q--)
    {
        int l,r,k;
        scanf("%d%d%d",&l,&r,&k);
        printf("%d\n",t[query(T[l],T[r+1],k)]);
    }
}
View Code

 

E - K-th Number POJ - 2104

标签:sid   unique   bbb   query   upd   quick   first   closed   sed   

原文地址:https://www.cnblogs.com/smallhester/p/10300566.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!