码迷,mamicode.com
首页 > 其他好文 > 详细

1092 To Buy or Not to Buy (字符串删除)

时间:2019-01-22 14:19:46      阅读:229      评论:0      收藏:0      [点我收藏+]

标签:info   figure   width   cas   idt   index   item   code   OLE   

1092 To Buy or Not to Buy (20 分)

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let‘s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

技术分享图片

Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

思路:
  这个题目算是目前遇到的最简单的了。我的办法是遍历eva的字符串,对于该字符串中的每一个字符,在店主的字符串中查找,如果没有找到,
则缺少一个字符,如果找到了,则把在店主的字符串中去除这个字符。最后如果lack变量大于0,则输出No,否则输出店主字符串的长度即可。
这样做的确可以通过,并且不会超时,看了一下别人的解法,感觉其他人的使用哈希或者dfs都很复杂。
技术分享图片
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
#include<set>
using namespace std;



int main()
{
    string owner,eva;
    cin>>owner>>eva;
    int lack=0;
    for(int i=0;i<eva.size();i++)
    {
        size_t index=owner.find(eva[i]);
        if(index!=string::npos)
            owner.erase(index,1);
        else
            lack++;
    }
    if(lack>0)
        cout<<"No "<<lack;
    else
        cout<<"Yes "<<owner.size();
    return 0;
}

 

 

1092 To Buy or Not to Buy (字符串删除)

标签:info   figure   width   cas   idt   index   item   code   OLE   

原文地址:https://www.cnblogs.com/zhanghaijie/p/10303285.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!