码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 3329 One Person Game (概率DP )

时间:2014-10-16 19:09:22      阅读:268      评论:0      收藏:0      [点我收藏+]

标签:style   blog   color   io   os   ar   for   strong   sp   

One Person Game

Time Limit: 1 Second      Memory Limit: 32768 KB      Special Judge

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter‘s number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698

思路:dp[i]=∑(dp[i+k]*p[k])+dp[0]*p0+1;  (k=3..k1+k2+k3) //dp[i]:从该点走到游戏结束的期望步数。

因为对于固定的k1、k2、k3,求得dp[0]是一个定值。

可以设dp[i]=A[i]*dp[0]+B[i]; 带入上式可以得到dp[i]=(∑(p[k]*A[i+k])+p0)dp[0]+∑(p[k]*A[i+k])+p0;

A[i]=∑(p[k]*A[i+k])+p0;

B[i]=∑(p[k]*A[i+k])+p0;

则:dp[0]=(1-A[i])/B[0];

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define N 550        <span style="white-space: pre-wrap; font-family: 'Microsoft YaHei';">//数组不能开小了!!</span>
#define LL __int64
const int inf=0x1f1f1f1f;
const double eps=1e-10;
double p[20],A[N],B[N],p0;
int main()
{
    int T,i,j,k,n,a,b,c,k1,k2,k3;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d%d%d%d%d",&n,&k1,&k2,&k3,&a,&b,&c);
        double p0=1.0/(k1*k2*k3);
        memset(p,0,sizeof(p));
        for(i=1; i<=k1; i++)
        {
            for(j=1; j<=k2; j++)
            {
                for(k=1; k<=k3; k++)
                {
                    if(i==a&&j==b&&k==c)
                        continue;
                    p[i+j+k]+=p0;
                }
            }
        }
        memset(A,0,sizeof(A));
        memset(B,0,sizeof(B));
        for(i=n; i>=0; i--)
        {
            A[i]=p0;
            B[i]=1;
            for(j=1; j<=(k1+k2+k3); j++)
            {
                A[i]+=A[i+j]*p[j]; 
                B[i]+=B[i+j]*p[j];
            }
        }
        printf("%.10f\n",B[0]/(1.0-A[0]));
    }
    return 0;
}






zoj 3329 One Person Game (概率DP )

标签:style   blog   color   io   os   ar   for   strong   sp   

原文地址:http://blog.csdn.net/u011721440/article/details/40150221

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!