码迷,mamicode.com
首页 > 其他好文 > 详细

1041 Be Unique 散列

时间:2019-01-24 15:35:50      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:signed   bottom   space   class   main   8 8   import   ted   ram   

1041 Be Unique (20 分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10?4??]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (10?5??) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None
思路
  散列,使用vector会省空间
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
#include<set>
#include<stack>
using namespace std;
vector<int> input;
int a[10005];

int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        int temp;
        cin>>temp;
        input.push_back(temp);
        a[temp]++;
    }
    for(auto temp:input)
    {
        if(a[temp]==1)
        {
            cout<<temp;
            return 0;
        }


    }
    cout<<"None";
    return 0;
}

 



1041 Be Unique 散列

标签:signed   bottom   space   class   main   8 8   import   ted   ram   

原文地址:https://www.cnblogs.com/zhanghaijie/p/10314666.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!