码迷,mamicode.com
首页 > 其他好文 > 详细

poj3176--Cow Bowling(dp:数塔问题)

时间:2014-10-16 22:52:03      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   os   ar   for   strong   sp   

Cow Bowling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14028   Accepted: 9302

Description

The cows don‘t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow‘s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample: 

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
 
 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[400][400] ;
int main()
{
    int n , i , j , max1 ;
    while(scanf("%d", &n) !=EOF)
    {
        max1 = 0 ;
        memset(dp,0,sizeof(dp));
        for(i = 1 ; i <= n ; i++)
            for(j = 1 ; j <= i ; j++)
                scanf("%d", &dp[i][j]);
        for(i = 1 ; i <= n ; i++)
            for(j = 1 ; j <= i ; j++)
                dp[i][j] = max( dp[i-1][j-1],dp[i-1][j] ) + dp[i][j] ;
        for(i = 1 ; i <= n ; i++)
            max1 = max(max1,dp[n][i]);
        printf("%d\n", max1);
    }
    return 0;
}

 

poj3176--Cow Bowling(dp:数塔问题)

标签:des   style   blog   io   os   ar   for   strong   sp   

原文地址:http://blog.csdn.net/winddreams/article/details/40154183

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!