码迷,mamicode.com
首页 > 其他好文 > 详细

1106 Lowest Price in Supply Chain (25 分)dfs

时间:2019-01-26 19:35:35      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:eve   algo   limits   sed   sub   str   eof   tween   number   

1106 Lowest Price in Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (10?5??), the total number of the members in the supply chain (and hence their ID‘s are numbered from 0 to N?1, and the root supplier‘s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K?i?? ID[1] ID[2] ... ID[K?i??]

where in the i-th line, K?i?? is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID‘s of these distributors or retailers. K?j?? being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10?10??.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

1.8362 2
思路:
  最小层一定要初始化的足够大,不然会有几个错误。
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
#include<set>
#include<stack>
#include<string.h>
#include<cstdio>
#include<cmath>
#include<limits.h>
#include<cfloat>
using namespace std;
struct Node
{
    double price;
    bool isRetail=false;
};
bool visited[100005];
Node node[100005];
vector<vector<int>>graph;
double lowPrice=DBL_MAX;
int cnt=0;
void findLowest(int id,double r)
{
    if(node[id].isRetail)
    {
        if(node[id].price<lowPrice)
        {
            lowPrice=node[id].price;
            //cout<<"1  "<<lowPrice<<endl;
            cnt=1;
        }
        else if(node[id].price==lowPrice)
            cnt++;
    }
    for(auto num:graph[id])
    {

        //visited[num]=true;
        node[num].price=node[id].price*(1+r/100);
       // cout<<node[num].price<<endl;
        findLowest(num,r);
    }
}

int main()
{
    int n;
    double p,r;
    cin>>n>>p>>r;
    graph.resize(n);
    int count[n];
    memset(count,0,sizeof(count));
    for(int i=0; i<n; i++)
    {
        int k;
        scanf("%d",&k);
        if(k==0)
        {
            node[i].isRetail=true;
            continue;
        }
        int temp;
        for(int j=0; j<k; j++)
        {
            scanf("%d",&temp);
            graph[i].push_back(temp);
        }
    }
    node[0].price=p;
   // fill(visited,visited+n,false);
    findLowest(0,r);
   // cout<<lowPrice<<" "<<cnt<<endl;
    printf("%.4f %d",lowPrice,cnt);
    return 0;
}

 

 

1106 Lowest Price in Supply Chain (25 分)dfs

标签:eve   algo   limits   sed   sub   str   eof   tween   number   

原文地址:https://www.cnblogs.com/zhanghaijie/p/10324600.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!