码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4006 The kth great number

时间:2019-01-27 13:03:02      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:get   nbsp   har   you   write   osi   print   iostream   sum   

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

InputThere are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.
OutputThe output consists of one integer representing the largest number of islands that all lie on one line.
Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

Sample Output

1
2
3


        
 

Hint

Xiao  Ming  won‘t  ask  Xiao  Bao  the  kth  great  number  when  the  number  of  the  written number is smaller than k. (1=<k<=n<=1000000).
#include <cstdio>
#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <queue>

using namespace std;

#define ll long long

char ming;

int n, k, r, sum;

int main()
{
    priority_queue<int, vector<int>, greater<int> >q;
    while(~scanf("%d%d", &n, &k))
    {
        while(q.size()) q.pop();
        for(int i = 0; i<n; i++)
        {
            getchar();
            scanf("%c", &ming);
            if(ming == Q)
            {
                printf("%d\n", q.top());
            }
            else
            {
                scanf("%d", &r);
                if(q.size() < k) q.push(r);
                else if(q.top()<r)
                {
                    q.pop();
                    q.push(r);
                }
            }
        }
    }
    return 0;
}

 

HDU 4006 The kth great number

标签:get   nbsp   har   you   write   osi   print   iostream   sum   

原文地址:https://www.cnblogs.com/RootVount/p/10325863.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!