码迷,mamicode.com
首页 > 其他好文 > 详细

1057 Stack (30 分)分桶法

时间:2019-01-27 19:03:31      阅读:242      评论:0      收藏:0      [点我收藏+]

标签:median   msu   imp   ios   pts   not   print   namespace   format   

1057 Stack (30 分)

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (10?5??). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 10?5??.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
#include<set>
#include<stack>
#include<string.h>
#include<cstdio>
#include<cmath>
using namespace std;
int cnt[100005];
int bucket[100005];
int Sqrt=113;//常数
int main()
{
    int n;
    scanf("%d",&n);
    stack<int>st;
   // st.reserve(n);
    for(int i=0; i<n; i++)
    {
        char ch[30];
        scanf("%s",ch);
        if(ch[1]==o)
        {
            if(!st.empty())
            {
                printf("%d\n",st.top());
                cnt[st.top()]--;
                bucket[st.top()/Sqrt]--;
                st.pop();
            }
            else
                printf("Invalid\n");
        }
        else if(ch[1]==e)
        {
            if(!st.empty())
            {
                int length=st.size();
                int m=length%2==0?length/2:(length+1)/2;
                int id=0,sum=0;
                while(sum+bucket[id]<m) sum+=bucket[id++];
                id=id*Sqrt;
                while(sum+cnt[id]<m) sum+=cnt[id++];
                printf("%d\n",id);
            }
            else
            {
                printf("Invalid\n");
            }
        }
        else
        {
            int b;
            scanf("%d",&b);
            st.push(b);
            cnt[b]++;
            bucket[b/Sqrt]++;
            //minNum=minNum>b?b:minNum;
        }
    }
    return 0;
}

 

 

1057 Stack (30 分)分桶法

标签:median   msu   imp   ios   pts   not   print   namespace   format   

原文地址:https://www.cnblogs.com/zhanghaijie/p/10327136.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!