码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 甲级 1150 Travelling Salesman Problem

时间:2019-01-29 13:58:38      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:possible   rect   nts   file   在线   exist   mes   fir   printf   

https://pintia.cn/problem-sets/994805342720868352/problems/1038430013544464384

 

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

C?1?? C?2?? ... C?n??

where n is the number of cities in the list, and C?i??‘s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8
 

代码:

#include <bits/stdc++.h>
using namespace std;

#define inf 0x3f3f3f3f
int N, M, K;
int dis[220][220];
int vis[220], go[220];

int main() {
    scanf("%d%d", &N, &M);
    memset(dis, inf, sizeof(dis));
    while(M --) {
        int st, en, cost;
        scanf("%d%d%d", &st, &en, &cost);
        if(cost < dis[st][en]) {
            dis[st][en] = cost;
            dis[en][st] = dis[st][en];
        }
    }

    scanf("%d", &K);
    int temp = 0, ans = INT_MAX;
    for(int k = 1; k <= K; k ++) {
        int T;
        bool can = false;
        int cnt1 = 0, cnt2 = 0;
        memset(vis, 0, sizeof(vis));
        bool flag = true;
        int sum = 0;
        scanf("%d", &T);
        for(int i = 1; i <= T; i ++) {
            scanf("%d", &go[i]);
            vis[go[i]] ++;
            if(i > 1) {
                if(dis[go[i]][go[i - 1]] != inf) {
                    sum += dis[go[i]][go[i - 1]];
                }
                else flag = false;
            }
        }

        printf("Path %d: ", k);
        if(!flag)
            printf("NA (Not a TS cycle)\n");
        else {
            int iscycle = 0;
            for(int i = 1; i <= N; i ++) {
                if(vis[i] == 0)
                    iscycle = 1;
                if(vis[i] == 1) cnt1 ++;
                if(vis[i] > 1) cnt2 ++;
            }

            if(iscycle == 1) printf("%d (Not a TS cycle)\n", sum);
            else if(cnt2 == 1 && vis[go[1]] == 2) {
                can = true;
                printf("%d (TS simple cycle)\n", sum);
            }
            else if(cnt2 >= 1 && vis[go[1]] >= 2) {
                can = true;
                printf("%d (TS cycle)\n", sum);
            }
            else if(cnt2 >= 1 && vis[go[1]] < 2)
                printf("%d (Not a TS cycle)\n", sum);
            else printf("%d (Not a TS cycle)\n", sum);

            if(can && sum < ans) {
                ans = sum;
                temp = k;
            }

        }

    }

    printf("Shortest Dist(%d) = %d\n", temp, ans);
    return 0;
}

  被图论支配的上午 暴躁 Be 主 在线编程

FH 下午去攀岩 然而我一会有牛客的比赛 哭咧咧

PAT 甲级 1150 Travelling Salesman Problem

标签:possible   rect   nts   file   在线   exist   mes   fir   printf   

原文地址:https://www.cnblogs.com/zlrrrr/p/10333521.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!