码迷,mamicode.com
首页 > 其他好文 > 详细

1016 部分A+B (15 分)

时间:2019-01-31 19:14:06      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:sel   sum   ups   .net   mat   inf   hit   std   输出   

 

正整数 A 的“D?A??(为 1 位整数)部分”定义为由 A 中所有 D?A?? 组成的新整数 P?A??。例如:给定 A=3862767,D?A??=6,则 A的“6 部分”P?A?? 是 66,因为 A 中有 2 个 6。

现给定 A、D?A??、B、D?B??,请编写程序计算 P?A??+P?B??。

输入格式:

输入在一行中依次给出 A、D?A??、B、D?B??,中间以空格分隔,其中 0<A,B<10?10??。

输出格式:

在一行中输出 P?A??+P?B?? 的值。

输入样例 1:

3862767 6 13530293 3

输出样例 1:

399

输入样例 2:

3862767 1 13530293 8

输出样例 2:

0
#include<iostream>
#include<string>
#include<cmath>
using namespace std;
int main()
{
    string a,b;
    int a1,b1,a2=0,b2=0;
    int asum=0,bsum=0; 
    cin>>a>>a1>>b>>b1;
    for(int i=0;i<a.size();i++)
        if(a[i]-0==a1)a2++;
    for(int i=0;i<b.size();i++)
        if(b[i]-0==b1)b2++;
    while(a2)
    {
        asum+=a1*pow(10.0,a2-1);
        a2--;
    }    
    while(b2)
    {
        bsum+=b1*pow(10.0,b2-1); 
        b2--;
    }
    cout<<asum+bsum;
}

 

考察对字符串的处理。

 

参考https://blog.csdn.net/qq_40167974/article/details/81158646

1016 部分A+B (15 分)

标签:sel   sum   ups   .net   mat   inf   hit   std   输出   

原文地址:https://www.cnblogs.com/xx123/p/10343063.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!