码迷,mamicode.com
首页 > 其他好文 > 详细

PAT A1039、A1047——vector常见用法

时间:2019-02-02 00:44:38      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:ted   ast   ctc   letter   com   integer   osi   std   cap   

A1039.Course List for Student

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N?i?? (≤200) are given in a line. Then in the next line, N?i?? student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student‘s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
Sample Input:

    11 5
    4 7
    BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
    1 4
    ANN0 BOB5 JAY9 LOR6
    2 7
    ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
    3 1
    BOB5
    5 9
    AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
    ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

    ZOE1 2 4 5
    ANN0 3 1 2 5
    BOB5 5 1 2 3 4 5
    JOE4 1 2
    JAY9 4 1 2 4 5
    FRA8 3 2 4 5
    DON2 2 4 5
    AMY7 1 5
    KAT3 3 2 4 5
    LOR6 4 1 2 4 5
    NON9 0

 

题意:

  有N个学生,K门课。现在给出选择每门课的学生姓名,并在之后给出N个学生姓名,要求按顺序给出每个学生的选课情况


参考代码:

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int N = 40010;    //总人数
const int M = 26*26*26*10 + 1;  //由姓名散列成的数字上届
vector<int> selectCourse[M];    //每个学生选择的课程编号

int getID(char name[]) {    //hash函数,将字符串name转换成数字
    int id = 0;
    for(int i = 0; i<3; i++){
        id = id*26 + (name[i] - ‘A‘);
    }
    id = id * 10 + (name[3] - ‘0‘);
    return id;
}

int main(){
    char name[5];
    int n,k;
    scanf("%d%d",&n,&k);    //人数及课程数
    for(int i=0; i<k; i++){     //对每门课程
        int course, x;
        scanf("%d%d", &course, &x);     //输入课程编号及选课人数
        for(int j = 0; j < x; j++){
            scanf("%s", name);      //输入选课学生姓名
            int id = getID(name);   //将姓名散列为一个整数作为编号
            selectCourse[id].push_back(course);     //将该课程编号加入学生选择中
        }
    }
    for(int i = 0; i < n; i++){     //n各查询
        scanf("%s", name);      //学生姓名
        int id = getID(name);       //获得学生编号
        sort(selectCourse[id].begin(),selectCourse[id].end());      //从小到大排序
        printf("%s %d",name,selectCourse[id].size());   //姓名、选课数
        for(int j = 0; j < selectCourse[id].size(); j++){
            printf(" %d",selectCourse[id][j]);      //选课编号
        }
        printf("\n");
    }
    return 0;
}

1047 Student List for Course

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (40,000), the total number of students, and K (2,500), the total number of courses. Then N lines follow, each contains a student‘s name (3 capital English letters plus a one-digit number), a positive number C (20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students‘ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

题意:
  给出选课人数和课程数目,然后再给出每个人的选课情况,请针对每门课程输出选课人数以及所有选该课的学生姓名

参考代码:
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 40010; //最大的学生人数
const int maxc = 2510;  //最大课程门数

char name[maxn][5];     //maxn个学生
vector<int> course[maxc];   //course[i]存放第i门课的所有学生编号

bool cmp(int a, int b) {
    return strcmp(name[a], name[b]) < 0;    //按姓名字典序从小到大排序
}

int main() {
    int n,k,c,courseID;
    scanf("%d%d", &n, &k);  //学生人数及课程数
    for(int i = 0; i < n; i++) {
        scanf("%s %d", name[i], &c);    //学生姓名及选课数
        for(int j = 0; j < c; j++) {
            scanf("%d", &courseID);     //选择的课程编号
            course[courseID].push_back(i);      //将学生i加入第courseID门课中
        }
    }
    for(int i = 1; i <= k; i++) {
        printf("%d %d\n", i, course[i].size());     //第i门课的学生数
        sort(course[i].begin(), course[i].end(),cmp);       //对第i门课的学生排序
        for(int j = 0; j < course[i].size(); j++) {
            printf("%s\n", name[course[i][j]]);      //输出学生姓名
        }
    }
    return 0;
}

PAT A1039、A1047——vector常见用法

标签:ted   ast   ctc   letter   com   integer   osi   std   cap   

原文地址:https://www.cnblogs.com/mxj961116/p/10347383.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!