码迷,mamicode.com
首页 > 其他好文 > 详细

More Is better-并查集

时间:2019-02-04 14:04:42      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:nes   fir   合并   chosen   media   lin   first   ant   use   

原题链接:https://vjudge.net/problem/11137/origin

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang‘s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
Sample Output
4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

题解:题目的意思就是找出数量最多的那个集合,并查集也就最后扫一下se就可以了(感觉树状数组也能做),这里有个特判点就是当n为0的时候是输出1的(这样最大的集合人数为1).差点1a了.

#include <bits/stdc++.h>
const int N=1e7+5;
using namespace std;
int se[N];
int ma[N];
int fd(int a){
    int x=a;
    while(se[x]!=x){
        x=se[x];
        for(int i=a,j;i!=x;i=j){
            j=se[i];
            se[i]=x;
        }
    }
    return x;
}
void join(int a,int b){
    int fa=fd(a);
    int fb=fd(b);
    se[fb]=fa;
}
int main()
{
    int n;
    while(~scanf("%d",&n)){
        if(n==0){
            printf("1\n");
            continue;
        }
        for(int i=1;i<=2*n;i++) se[i]=i;
        for(int i=1;i<=n;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            join(a,b);
        }
        memset(ma,0,sizeof(ma));
        for(int i=1;i<=2*n;i++) ma[fd(i)]++;
        int ans=0;
        for(int i=1;i<=2*n;i++) ans=max(ans,ma[i]);
        printf("%d\n",ans);
    }

    //cout << "Hello world!" << endl;
    return 0;
}

More Is better-并查集

标签:nes   fir   合并   chosen   media   lin   first   ant   use   

原文地址:https://www.cnblogs.com/-yjun/p/10351653.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!