码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 甲级 1051 Pop Sequence

时间:2019-02-06 22:28:31      阅读:169      评论:0      收藏:0      [点我收藏+]

标签:ret   http   cto   not   tac   imu   check   targe   mic   

https://pintia.cn/problem-sets/994805342720868352/problems/994805427332562944

 

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

代码:

#include <bits/stdc++.h>
using namespace std;

int N, M, K;
vector<int> v;

int main() {
    scanf("%d%d%d", &M, &N, &K);
    while(K --) {
        bool flag = false;
        v.resize(N + 1);
        int cnt = 1;
        for(int i = 1; i <= N; i ++)
            scanf("%d", &v[i]);

        stack<int> s;
        for(int i = 1; i <= N; i ++) {
            s.push(i);
            if(s.size() > M) break;
            while(!s.empty() && s.top() == v[cnt]) {
                s.pop();
                cnt ++;
            }
        }

        if(cnt == N + 1) flag = true;
        if(flag) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

  感觉年就这么结束了诶

FH

PAT 甲级 1051 Pop Sequence

标签:ret   http   cto   not   tac   imu   check   targe   mic   

原文地址:https://www.cnblogs.com/zlrrrr/p/10354106.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!