码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 甲级 1057 Stack

时间:2019-02-09 17:36:03      阅读:326      评论:0      收藏:0      [点我收藏+]

标签:instead   fun   fine   val   hit   media   comm   eve   not   

https://pintia.cn/problem-sets/994805342720868352/problems/994805417945710592

 

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (-th smallest element if N is even, or (-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 1.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5 + 10;
int N;
int c[maxn];
stack<int> s;

int lowerbit(int x) {
    return x & -x;
}

void update(int x, int v) {
    for(int i = x; i < maxn; i += lowerbit(i))
        c[i] += v;
}

int getsum(int x) {
    int sum = 0;
    for(int i = x; i >= 1; i -= lowerbit(i))
        sum += c[i];
    return sum;
}

void PeekMedian() {
    int left = 1, right = maxn, mid, k = (s.size() + 1) / 2;
    while(left < right) {
        mid = (left + right) / 2;
        if(getsum(mid) >= k)
            right = mid;
        else left = mid + 1;
    }
    printf("%d\n", left);
}

int main() {
    scanf("%d", &N);
    while(N --) {
        string op;
        cin >> op;
        if(op == "Pop") {
            if(s.empty()) printf("Invalid\n");
            else {
                printf("%d\n", s.top());
                update(s.top(), -1);
                s.pop();
            }
        } else if(op == "Push") {
            int num;
            scanf("%d", &num);
            s.push(num);
            update(num, 1);
        } else {
            if(s.empty()) printf("Invalid\n");
            else PeekMedian();
        }
    }
    return 0;
}

  树状数组 第一次写到树状数组 看博客还没看的很懂但是隐约感觉到这是一个模板题 emmmm 以后多做一点就会明白了叭 唉 哭唧唧

FH

PAT 甲级 1057 Stack

标签:instead   fun   fine   val   hit   media   comm   eve   not   

原文地址:https://www.cnblogs.com/zlrrrr/p/10357628.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!