码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 甲级 1029 Median

时间:2019-02-12 21:26:04      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:highlight   sep   amp   bottom   define   line   mic   element   lin   

https://pintia.cn/problem-sets/994805342720868352/problems/994805466364755968

 

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (2×10?5??) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13
 

代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 2e5 + 10;
int N, M;
int a[maxn];

int main() {
    scanf("%d", &N);
    for(int i = 1; i <= N; i ++)
        scanf("%d", &a[i]);
    a[N + 1] = INT_MAX;
    int cnt = 0;
    int temp;
    scanf("%d", &M);
    int mid = (N + M + 1) / 2;
    int i = 1;
    for(int j = 1; j <= M; j ++) {
        scanf("%d", &temp);
        while(a[i] < temp) {
            cnt ++;
            if(cnt == mid) printf("%d", a[i]);
            i ++;
        }
        cnt ++;
        if(cnt == mid) printf("%d", temp);
    }
    while(i < N) {
        cnt ++;
        if(cnt == mid) printf("%d", a[i]);
        i ++;
    }
    return 0;
}

  不能把两个数组合并起来再排序求中位数 会内存超限 先输入第一个数组之后 算出中位数是第几个 然后输入第二个数组 如果输入当前比第一个数组的起始的大 那么 cnt ++ 然后第一个数组向后挪一位 如果一直没有比第一个数组大的那么在第二个数组里继续计数 如果还不到 mid 那么回第一个数组中继续

FH

PAT 甲级 1029 Median

标签:highlight   sep   amp   bottom   define   line   mic   element   lin   

原文地址:https://www.cnblogs.com/zlrrrr/p/10366978.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!