码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1129 Channel Allocation

时间:2019-02-12 21:32:12      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:ann   splay   indent   inpu   nsis   repeater   n+2   win   cep   

Channel Allocation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 18033   Accepted: 9133

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 
 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

Source

 

【题意】

给一张n个点的无向完全图,任意相邻两点不同色,染遍全图,至少需要多少颜色。

技术图片

 

【分析】

n<=26,那枚举or搜索都可以啊。

PS:四色定理:对于一张无向完全图,任意相邻两点不同色,染遍全图,至多需要4种颜色。

推荐阅读一篇优质解题报告

 

【代码】

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int N=27;
int n,ans,c[N],g[N][N];
char s[N];
inline void Clear(){
	memset(c,0,sizeof c);
	memset(g,0,sizeof g);
}
inline void Init(){
	for(int i=1;i<=n;i++){
		scanf("%s",s);
		for(int j=2;s[j];j++){
			g[i][++g[i][0]]=s[j]-‘A‘+1;
		}
	}
}
inline void Solve(){
	ans=1;
	for(int i=1;i<=n;i++){
		bool vis[27]={0};c[i]=n+1;
		for(int j=1;j<=g[i][0];j++){
			int k=g[i][j];
			if(c[k]) vis[c[k]]=1;	
		}
		for(int j=1;j<=26;j++){
			if(!vis[j]&&c[i]>j){
				c[i]=j;break;
			}
		}
		if(ans<c[i]){
			ans=c[i];
			if(ans==4) break;//F C T
		} 
	}
	if(ans==1)
		printf("%d channel needed.\n",ans);
	else
		printf("%d channels needed.\n",ans);
}
int main(){
	while(scanf("%d",&n)==1&&n){
		Clear();
		Init();
		Solve();
	}
	return 0;
}

 

 

 

POJ 1129 Channel Allocation

标签:ann   splay   indent   inpu   nsis   repeater   n+2   win   cep   

原文地址:https://www.cnblogs.com/shenben/p/10367133.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!