码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2955_Robberies【01背包】

时间:2014-10-17 20:33:36      阅读:127      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   os   ar   java   for   

Robberies


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12462    Accepted Submission(s): 4623

Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.
bubuko.com,布布扣

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output
2
4

6


题目大意:有一个强盗要去几个银行偷盗,他既想多投点钱,又想尽量不被抓到。已知各个银行

的金钱数和被抓的概率,以及强盗能容忍的最大被抓概率。求他最多能偷到多少钱?

思路:背包问题,原先想的是把概率当做背包,在这个范围内最多能抢多少钱。

但是问题出在概率这里,一是因为概率是浮点数,用作背包必须扩大10^n倍来用。二是最大不

抓概率不是简单的累加。二是p = (1-p1)(1-p2)(1-p3) 其中p为最大不被抓概率,p1,p2,p3

为各个银行被抓概率。

第二次想到把银行的钱当做背包,把概率当做价值,总容量为所有银行的总钱数,求不超过被抓

概率的情况下,最大的背包容量是多少

 dp[j] = max(dp[j],dp[j-Bag[i].v]*(1-Bag[i].p))(dp[j]表示在被抢概率j之下能抢的钱);

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

struct bag
{
    int v;
    double p;
}Bag[10010];
double dp[10010];

int main()
{
    int T,N;
    double p;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf %d",&p,&N);
        int sum = 0;
        for(int i = 0; i < N; i++)
        {
            scanf("%d%lf",&Bag[i].v,&Bag[i].p);
            sum += Bag[i].v;
        }
        memset(dp,0,sizeof(dp));
        dp[0] = 1;
        for(int i = 0; i < N; i++)
        {
            for(int j = sum; j >= Bag[i].v; j--)
            {
                dp[j] = max(dp[j],dp[j-Bag[i].v]*(1-Bag[i].p));
            }
        }

        for(int i = sum; i >= 0; i--)
        {
            if(dp[i] > 1-p)
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}



HDU2955_Robberies【01背包】

标签:des   style   blog   http   io   os   ar   java   for   

原文地址:http://blog.csdn.net/lianai911/article/details/40183907

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!