码迷,mamicode.com
首页 > 其他好文 > 详细

PAT A1149 Dangerous Goods Packaging (25 分)

时间:2019-02-21 14:22:10      阅读:217      评论:0      收藏:0      [点我收藏+]

标签:orm   test   sim   注意   nta   判断   for   trouble   一个个   

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: N (10?4??), the number of pairs of incompatible goods, and M (100), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] ... G[K]

where K (1,000) is the number of goods and G[i]‘s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:

For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:

6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333

Sample Output:

No
Yes
Yes
 
#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <map>
#include <vector>
#include <set>
using namespace std;
int n, m, k;
set<int> adj[100001];
int inc[100001] = { 0 };
int req[110];
int main() {
    scanf("%d %d", &n, &m);
    for (int i = 0; i < n; i++) {
        int c1, c2;
        scanf("%d %d", &c1, &c2);
        adj[c1].insert(c2);
        adj[c2].insert(c1);
        inc[c1] = 1;
        inc[c2] = 1;
    }
    for (int i = 0; i < m; i++) {
        int flag = 0;
        scanf("%d", &k);
        for (int j = 0; j < k; j++) {
            scanf("%d", &req[j]);
        }
        for (int j = 0; j < k; j++) {
            if (flag == 0) {
                    for (int q = j + 1; q < k; q++) {
                        if (adj[req[j]].find(req[q]) != adj[req[j]].end()) {
                            flag = 1;
                            break;
                        }
                    }
                
            }
            else break;
        }
        printf("%s\n", flag == 0 ? "Yes" : "No");
    }
}

注意点:看到题目第一眼想到的是图的联通块,但想想第二题应该不会考图,还是用map来做,用map好像有点麻烦,一个对应多个的时候不方便,那用vector,不好判断在不在里面。最终还是用set比较好,就开一个很大的set数组,然后一个个去查找就好了,内存和时间都不超。

PAT A1149 Dangerous Goods Packaging (25 分)

标签:orm   test   sim   注意   nta   判断   for   trouble   一个个   

原文地址:https://www.cnblogs.com/tccbj/p/10412106.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!