码迷,mamicode.com
首页 > 其他好文 > 详细

uva 725 Division

时间:2019-02-25 23:10:32      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:tor   clu   git   div   spl   file   sample   ring   isp   

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where 2 ≤ N ≤ 79. That is, abcde fghij = N where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input

Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.

Output

Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).

Your output should be in the following general form:

xxxxx / xxxxx = N

xxxxx / xxxxx = N

In case there are no pairs of numerals satisfying the condition, you must write ‘There are no solutions for N.’. Separate the output for two different values of N by a blank line.

Sample Input

61

62

0

Sample Output

There are no solutions for 61.

79546 / 01283 = 62

94736 / 01528 = 62

 

代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;

int n;
int c;
bool check(int a,int b) {
    bool vis[10] = {false};
    for(int i = 0;i < 5;i ++) {
        if(vis[a % 10]) return false;
        vis[a % 10] = true;
        if(vis[b % 10]) return false;
        vis[b % 10] = true;
        a /= 10;
        b /= 10;
    }
    return true;
}
int main() {
    while(~scanf("%d",&n) && n) {
        if(c) putchar(\n);
        c = 0;
        for(int i = 1234;i < 50000;i ++) {
            int d = i * n;
            if(d > 98765) break;
            if(d < 12345) continue;
            if(check(i,d)) {
                printf("%05d / %05d = %d\n",d,i,n);
                c ++;
            }
        }
        if(!c) printf("There are no solutions for %d.\n",n);
        c = -1;
    }
}

 

uva 725 Division

标签:tor   clu   git   div   spl   file   sample   ring   isp   

原文地址:https://www.cnblogs.com/8023spz/p/10434487.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!