码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3639 Hawk-and-Chicken(Tarjan缩点+反向DFS)

时间:2014-10-18 22:26:11      阅读:291      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   io   os   ar   for   sp   div   

Problem Description
Kids in kindergarten enjoy playing a game called Hawk-and-Chicken. But there always exists a big problem: every kid in this game want to play the role of Hawk. 
So the teacher came up with an idea: Vote. Every child have some nice handkerchiefs, and if he/she think someone is suitable for the role of Hawk, he/she gives a handkerchief to this kid, which means this kid who is given the handkerchief win the support. Note the support can be transmitted. Kids who get the most supports win in the vote and able to play the role of Hawk.(A note:if A can win
support from B(A != B) A can win only one support from B in any case the number of the supports transmitted from B to A are many. And A can‘t win the support from himself in any case.
If two or more kids own the same number of support from others, we treat all of them as winner.
Here‘s a sample: 3 kids A, B and C, A gives a handkerchief to B, B gives a handkerchief to C, so C wins 2 supports and he is choosen to be the Hawk.
 

Input
There are several test cases. First is a integer T(T <= 50), means the number of test cases.
Each test case start with two integer n, m in a line (2 <= n <= 5000, 0 <m <= 30000). n means there are n children(numbered from 0 to n - 1). Each of the following m lines contains two integers A and B(A != B) denoting that the child numbered A give a handkerchief to B.
 

Output
For each test case, the output should first contain one line with "Case x:", here x means the case number start from 1. Followed by one number which is the totalsupports the winner(s) get. 
Then follow a line contain all the Hawks‘ number. The numbers must be listed in increasing order and separated by single spaces.
 

Sample Input
2 4 3 3 2 2 0 2 1 3 3 1 0 2 1 0 2
 

Sample Output
Case 1: 2 0 1 Case 2: 2 0 1 2
 
题意:选出人当老鹰:类似A->B,B->C=>A->C的,最后谁得到的多就选谁。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
typedef long long LL;
using namespace std;

#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )

const int maxn=5000+100;
const int maxm=100000+10;
struct node{
    int u,v;
    int next;
}e[maxm],e1[maxn];
int head[maxn],cntE,cntF;
int DFN[maxn],low[maxn],h[maxn];
int s[maxm],top,index,cnt;
int belong[maxn],instack[maxn];
int dp[maxn],in[maxn],vis[maxn];
int num[maxn];
int n,m;
void init()
{
    top=cntE=cntF=0;
    index=cnt=0;
    CLEAR(DFN,0);
    CLEAR(head,-1);
    CLEAR(instack,0);
}
void addedge(int u,int v)
{
    e[cntE].u=u;e[cntE].v=v;
    e[cntE].next=head[u];
    head[u]=cntE++;
}
void Tarjan(int u)
{
    DFN[u]=low[u]=++index;
    instack[u]=1;
    s[top++]=u;
    for(int i=head[u];i!=-1;i=e[i].next)
    {
        int v=e[i].v;
        if(!DFN[v])
        {
            Tarjan(v);
            low[u]=min(low[u],low[v]);
        }
        else if(instack[v])
            low[u]=min(low[u],DFN[v]);
    }
    int v;
    if(DFN[u]==low[u])
    {
        cnt++;
        do{
            v=s[--top];
            belong[v]=cnt;
            instack[v]=0;
        }while(u!=v);
    }
}
int dfs(int x)
{
    int ans=num[x];
    for(int i=h[x];i!=-1;i=e1[i].next)
    {
        int v=e1[i].v;
        if(!vis[v])
        {
            vis[v]=1;
            ans+=dfs(v);
        }
    }
    return ans;
}
void work()
{
    REP(i,n)
      if(!DFN[i])  Tarjan(i);
   if(cnt==1)
   {
       printf("%d\n",n-1);
       REP(i,n)
        printf(i==n-1?"%d\n":"%d ",i);
       return ;
   }
   CLEAR(num,0);
   CLEAR(dp,0);
   CLEAR(in,0);
   CLEAR(h,-1);
   REP(i,n)//马丹,这里卡了我两天
     num[belong[i]]++;
   REP(k,n)
   {
       for(int i=head[k];i!=-1;i=e[i].next)
       {
         int v=e[i].v;
         if(belong[k]!=belong[v])//反向建边dfs.
         {
//           cout<<"666  "<<endl;
           e1[cntF].u=belong[v];
           e1[cntF].v=belong[k];
           e1[cntF].next=h[belong[v]];
           h[belong[v]]=cntF++;
           in[belong[k]]++;
         }
       }
   }
   REPF(i,1,cnt)
   {
       if(!in[i])
       {
         CLEAR(vis,0);
         dp[i]=dfs(i)-1;
       }
   }
    int ans=0;
    REPF(i,1,cnt)
      ans=max(ans,dp[i]);
    printf("%d\n",ans);
    int flag=0;
    REP(i,n)
    {
        if(dp[belong[i]]==ans)
        {
           if(!flag)
              printf("%d",i),flag=1;
           else
              printf(" %d",i);
        }
    }
    printf("\n");
}
int main()
{
    int t,u,v;
    int cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        init();
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            addedge(u,v);
        }
        printf("Case %d: ",cas++);
        work();
    }
    return 0;
}


HDU 3639 Hawk-and-Chicken(Tarjan缩点+反向DFS)

标签:des   style   color   io   os   ar   for   sp   div   

原文地址:http://blog.csdn.net/u013582254/article/details/40217515

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!