码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4288-Coder(模拟)

时间:2014-10-18 22:26:54      阅读:293      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   java   

Coder

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3327    Accepted Submission(s): 1316


Problem Description
  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done. 1
  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete).
Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum.
  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations:
  1. add x – add the element x to the set;
  2. del x – remove the element x from the set;
  3. sum – find the digest sum of the set. The digest sum should be understood by
bubuko.com,布布扣

  where the set S is written as {a1, a2, ... , ak} satisfying a1 < a2 < a3 < ... < ak 
  Can you complete this task (and be then fired)?
------------------------------------------------------------------------------
1 See http://uncyclopedia.wikia.com/wiki/Algorithm
 

Input
  There’re several test cases.
  In each test case, the first line contains one integer N ( 1 <= N <= 105 ), the number of operations to process.
  Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”.
  You may assume that 1 <= x <= 109.
  Please see the sample for detailed format.
  For any “add x” it is guaranteed that x is not currently in the set just before this operation.
  For any “del x” it is guaranteed that x must currently be in the set just before this operation.
  Please process until EOF (End Of File).
 

Output
  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty.
 

Sample Input
9 add 1 add 2 add 3 add 4 add 5 sum add 6 del 3 sum 6 add 1 add 3 add 5 add 7 add 9 sum
 

Sample Output
3 4 题意:给一个集合(严格升序,无重复) add x是将x加入集合,del x是将x从集合中删除,sum是求下标%5==3的元素的和。
用数组模拟集合,插入和删除的时候要保证数组有序,然后求和暴力解决 6000+MS..
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <list>
#define ll long long
using namespace std;
const int INF=1<<27;
const int maxn=100010;
int a[maxn];
int Binary_search(int low,int high,int x)
{
	int mid;
	while(low<=high)
	{
		mid=(low+high)/2;
		if(a[mid]==x)
			return mid;
		else if(a[mid]>x)
			high=mid-1;
		else if(a[mid]<x)
			low=mid+1;
	}
	return -1;
}
int main()
{
	int n,x,i;char op[5];
	while(scanf("%d",&n)!=EOF)
	{
		int len=0;
		while(n--)
		{
			scanf("%s",op);
			if(op[0]=='a')
			{
				scanf("%d",&x);
				for(i=len++;i>0;i--)
					if(a[i-1]>x)
						a[i]=a[i-1];
					else
						break;
				a[i]=x;
			}
			else if(op[0]=='d')
			{
				scanf("%d",&x);
				int indx=Binary_search(0,len-1,x);
				while(indx<len-1)
				{
					a[indx]=a[indx+1];
					indx++;
				}
				len--;
			}
			else
			{
				__int64 sum=0;
				for(i=2;i<len;i+=5)
					sum+=a[i];
				printf("%I64d\n",sum);
			}
		}
	}
    return 0;
}

HDU 4288-Coder(模拟)

标签:des   style   blog   http   color   io   os   ar   java   

原文地址:http://blog.csdn.net/qq_16255321/article/details/40216965

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!