码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3661-Assignments(贪心)

时间:2014-10-18 22:28:01      阅读:341      评论:0      收藏:0      [点我收藏+]

标签:贪心

Assignments

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1554    Accepted Submission(s): 716


Problem Description
In a factory, there are N workers to finish two types of tasks (A and B). Each type has N tasks. Each task of type A needs xi time to finish, and each task of type B needs yj time to finish, now, you, as the boss of the factory, need to make an assignment, which makes sure that every worker could get two tasks, one in type A and one in type B, and, what‘s more, every worker should have task to work with and every task has to be assigned. However, you need to pay extra money to workers who work over the standard working hours, according to the company‘s rule. The calculation method is described as follow: if someone’ working hour t is more than the standard working hour T, you should pay t-T to him. As a thrifty boss, you want know the minimum total of overtime pay.
 

Input
There are multiple test cases, in each test case there are 3 lines. First line there are two positive Integers, N (N<=1000) and T (T<=1000), indicating N workers, N task-A and N task-B, standard working hour T. Each of the next two lines has N positive Integers; the first line indicates the needed time for task A1, A2…An (Ai<=1000), and the second line is for B1, B2…Bn (Bi<=1000).
 

Output
For each test case output the minimum Overtime wages by an integer in one line.
 

Sample Input
2 5 4 2 3 5
 

Sample Output
4
题意:n个工人,有n件工作a,n件工作b,每个工人干一件a和一件b,a[i] ,b[i]代表工作时间,如果a[i]+b[j]>t,则老板要额外付钱a[i]+b[j]-t;现在要求老板付钱最少;
一开始以为是dp,写了一会没写出来。。。后来看题解是贪心,说一下我自己的理解吧:a[]升序,b[]降序,然后对应相加;为什么要一个升序一个降序呢,我认为是这样的:对于没一个a[i],我们让尽量大的a[i]和尽量小的b[j]结合,这样可以让老板的付钱降到最低(证明无法给出。。sad)
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <list>
#define ll long long
using namespace std;
const int INF=1<<27;
const int maxn=1010;
int a[maxn],b[maxn];
int main()
{
	int n,t;
	while(scanf("%d%d",&n,&t)!=EOF)
	{
		for(int i=0;i<n;i++)
			scanf("%d",a+i);
		sort(a,a+n);
		for(int i=0;i<n;i++)
			scanf("%d",b+i);
		sort(b,b+n);
		int sum=0;
		for(int i=0;i<n;i++)
			sum+=(a[i]+b[n-1-i]>t?a[i]+b[n-1-i]-t:0);
		printf("%d\n",sum);
	}
    return 0;
}

HDU 3661-Assignments(贪心)

标签:贪心

原文地址:http://blog.csdn.net/qq_16255321/article/details/40216409

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!